Debian cant compilate files.

Discussion in 'Installation/Configuration' started by sshaddoww, Jan 6, 2012.

  1. sshaddoww

    sshaddoww New Member

    Im following this guide:

    Now im at the stage where I try the following command:
    ./debian/rules binary
    But then this error appears:
    checking whether we are cross compiling... configure: error: in `/tmp/jailkit-2.13':
    configure: error: cannot run C compiled programs.
    If you meant to cross compile, use `--host'.
    See `config.log' for more details.
    make: *** [config.status] Error 1
    I have checked so that "gcc is already the newest version.".
    libpq5 is also installed.

    Why cant my install compile this?

    Earlier when I tried to install ISPConfig2 (did not know about the new one) I got a similiar, compiler related, error:
    /usr/include/gnu/stubs.h:9:27: error: gnu/stubs-64.h: No such file or directory
    In file included from ../include/openssl/crypto.h:125,
                     from cryptlib.h:72,
                     from cryptlib.c:117:
    /usr/include/stdio.h:641:2: error: invalid preprocessing directive #extern
    /usr/include/stdio.h:642:10: error: invalid preprocessing directive #size_t
    /usr/include/stdio.h:643:10: error: invalid preprocessing directive #FILE
    make[1]: *** [cryptlib.o] Error 1
    make[1]: Leaving directory `/root/install_ispconfig/compile_aps/openssl-0.9.8r/crypto'
    make: *** [build_crypto] Error 1
    ERROR: Could not make OpenSSL
    How should I patch my debian so I can install stuff?
  2. falko

    falko Super Moderator ISPConfig Developer

    apt-get install binutils-gold
    and try again.

Share This Page