Debian 9 network configuration

Discussion in 'Installation/Configuration' started by Samo_A86, Oct 5, 2017.

  1. Samo_A86

    Samo_A86 New Member

    I can't configure to use a static IP. Can this be a because of my router?
    In my /etc/network/interfaces I don't even have the lines:
    # The primary network interface
    auto eth0
    iface eth0 inet static

    the network interface I get with ip a is enp1s0 and if I add (not real IPs)
    allow-hotplug enp1s0
    iface enp1s0 inet static
    address 10.1.1.125
    netmask 255.0.0.0
    gateway 10.1.1.1

    the network just doesn't work.
    Tried everything google found and nothing worked. Does anyone know what can be the problem and how to fix it?
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    is the enp1s0 up? you have no auto in there
    $ifup enp1s0
    assuming the address is not already in use and the other settings are correct, it should work.
    maybe you delete the eth0 stuff, try a reboot.

    the naming has been changed, yes it looks silly at first, but before having multiple ethernet cards could led to the one beeing eth0 and next reboot the other ....

    however, you can revert to the old behaviour
    change
    /etc/default/grub

    Code:
    GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"
    
    $grub-mkconfig -o /boot/grub/grub.cfg
     
    Samo_A86 likes this.
  3. Samo_A86

    Samo_A86 New Member

    nope... didn't delete it and the IP isn't in use. Have configured a lot of Ubuntu servers so I did this interface config a lot of times.

    Thanks for the GRUB config now I have eth0. Tried different IPs but they don't work. The router IP is correct checked it on 2 different PCs and I copied the configuration so it can't be misspelling. Realy don't know what can be the problem other than maybe the router won't let me connect.
     
  4. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    hmm MAC-filter? is some sort of network-manager running in the background reconfigureing networks?
    what's your $ifconfig after boot - as expected?
    Is this a virtual machine having a bond with the "wrong" network card/setting?
    something in network/interfaces.d or /etc/network/if-[pre]-up.d ?
    flushed iptables rules?
    $route -n
    looks good?
    traceroute ends at which hop?
     
  5. Samo_A86

    Samo_A86 New Member

    I just don't know anymore. Will try a fresh install or an install of ubuntu to see if I run into the same problem. Thanks for all the help. It isn't a VM and I know how to configure bridge connections.
     

Share This Page