Debian 9: mpm_worker, php-fpm ( roundcube, enigma, munin, phpmyadmin aliases fix )

Discussion in 'Tips/Tricks/Mods' started by ztk.me, Oct 5, 2017.

  1. Jesse Norell

    Jesse Norell Well-Known Member

    I did not, I put it in a server - wide conf file.
     
  2. sunghost

    sunghost Member

    Hi Jesse,
    do you mean to add it into .vhost? Can you describe it more in detail?
    It whould be nice if my customer can enter webmail, phpmyadmin via www.company-name.tld/webmail or /phpmyadmin
    Thx
     
  3. sunghost

    sunghost Member

    Hi,
    website reported 503 and i found in Apache error.log:
    Code:
    proxy_fcgi:error] [pid 31879:tid 140129196824320] AH01079: failed to make connection to backend: httpd-UDS
    [Thu Jan 31 12:58:50.242593 2019] [proxy:error] [pid 31882:tid 140129079326464] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.0-fpm.sock (*) failed
    
    Strange because i enabled PHP 7.2 for this site.

    edit: i now delete apache directive entries and take them to apache conf-available and then a2enconf phpmyadmin, but it doesnt solve the problem.

    edit: i reading the whole day and iam confused now. Am i right that i can configure Web Domain in ISP with PHP Fast-CGI Option and mpm_event, or must i change PHP Option to PHP-FPM?
     
    Last edited: Jan 31, 2019
  4. sunghost

    sunghost Member

    No help since 12:30 Clock ! ;( I installed all on local Testserver and it works without an extra fqdn site. I compared installed php packages, phpmyadmin and roundcube.conf in apache, restarted services and it looks normal, but roundcube and phpmyadmin didnt work. Need help!
     
  5. Jesse Norell

    Jesse Norell Well-Known Member

    There is an example earlier in this thread: https://www.howtoforge.com/communit...pmyadmin-aliases-fix.77489/page-3#post-378761

    You should be able to use fpm mode for both the server's default php (and disable mod_php) as well as for your website. You might run through this thread again. I have some notes I'd need to refer to to refresh my memory on the specifics, but I know when installing php from the ondrej sury repos on debian 9, it was pretty simple to setup (eg. just a2dismod the old php version, a2enconf the new php-fpm version, and the /phpmyadmin and /webmail links worked on customer sites "out of the box," iirc).
     
  6. sunghost

    sunghost Member

    Hi Jesse,
    i run x times through it and tested it meanwhile local on my testsystem. I have no problems on my testsystem, but i cant use lets encrypt, but i tried with only http on liveserver for one site as well with http, but evertime i get 503 Service Unavailable. I switch for a test php on Webdomain to php-fpm, but it didnt work, so i go back to fast-cgi. I am searching the whole day and no i am confused about ispconfig, http2 and phmyadmin and roudcube. I dont know where to look further and in 5h i have to go to work, so i am done.

    I want my system as Debian stable and fast as possible, but so i didnt use the PHP Version from ondrej, but i think it should work elsewhere. The Problem is not http2 nor PHP, because i compiled it like Till told in his HowTos as additional PHP-Versions. My Websites load via http2 and it looks ok with PHP 7.2 and also 7.1, but webmail and phpmyadmin is an problem.
     
  7. ahrasis

    ahrasis Well-Known Member

    I think you should post your vhost and error log files, if any, to ease others to help you (but I can't help with apache2 as I have been using nginx for quite sometimes and now forgot everything about apache2).
     
  8. sunghost

    sunghost Member

    Hi ahrasis,
    there is nothing to be find in the logs. Plan B. If this with Apache and FastCGI and mpm_event and http2 and phpmyadmin not working, i think about creating an Subdomain to my website.tld as phpmyadmin.website.tld and webmail.website.tld. ISP is configured in the way it creates seperate fodler and user. What you guys think about that? Security and functionality?
     
  9. Jesse Norell

    Jesse Norell Well-Known Member

    If you're getting a 503 error, I'd guess your php init scripts and ispconfig setup don't mesh, try running through the perfect server tutorial and the tutorial to compile your own php versions. Self compiled php definitely works if it's setup right. The precompiled repo is much easier/quicker to use, and I would be very surprised if there's any speed difference.

    Those use the default php interpreter for the system. The tutorial to compile your own php versions only configures those for use under websites, they do not change the default system php version. In a quick look at the perfect server guide for stretch + apache, I think the default php for apache would be 7.0 in mod_php mode. You can easily change that to fpm mode, just a2dismod the mod_php module and a2enconf the fpm config (which is installed as part of that tutorial)

    It is often recommended to not change the system php version at all as it can and does break things at times, but in your specific environment (debian 9 w/ apache) I can report that I'm using php7.1-fpm as the default php version in apache without a problem (eg. phpmyadmin works, as does the ispconfig panel). I don't know if I tried 7.2 offhand.
     
  10. sunghost

    sunghost Member

    Hi Jesse,
    i figure it out and it came from upgrading Debian Jessi to Stretch. I had installed still the PHP5 Packages. After removing all and reconfigure Debian stable PHP7.0 Packages, all went well. Thx all for helping.
     

Share This Page