debian 9 Ispconfig3 + postfix RELAY DENIED errors

Discussion in 'Installation/Configuration' started by ajajaj2, Apr 18, 2019.

  1. ajajaj2

    ajajaj2 New Member HowtoForge Supporter

    so, we set up a new debian 9 system, then did the ispconfig migration from old system to new one, and all of a sudden we get RELAY DENIED errors in postfix.

    I have looked at the main.cf file on both machines and the new one is missing a whole bunch of references to mysql-virtual stuff.

    any ideas where to look? did I miss something in the install?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    In what situation? Usually it is desired to disable relaying. Can you show the fuil error message with context?
     
  3. ajajaj2

    ajajaj2 New Member HowtoForge Supporter

    Hi Taleman

    The new server is also the primary MX for email now - so it seems as if postfix does not know about the fact that this domain and users are configured to receive email at it.

    I tried copying the mysql:/etc/postfix/mysql-virtual_client.cf stuff from old main.cf
    However it tells me that there is no such file/dir

    It feels to me like the postfix-mysql stuff is not working - as in postfix does not know about the virtual tables that ispconfig should be putting in.

    edit: however on the perfect server setup, it says nothing about the mysql integration with postfix in order to allow postfix to know what ispconfig wants it to do regards virtual email domains
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    My quess is either certificate for this new mail server does not exist or is faulty. Or postfix setup is missing mydestination or recipient_restrictions so postfix does not accept mails from you local network.
     
  5. ajajaj2

    ajajaj2 New Member HowtoForge Supporter

    ok, thanks - is this usually set up by Ispconfig on setup? or did I miss a step? have installed on many older debians without issue, this is first time it is not working (debian stretch)
     
  6. ajajaj2

    ajajaj2 New Member HowtoForge Supporter

    OK, further to this it seems as if the *.cf files were not created when ispconfig was installed.
     
  7. ajajaj2

    ajajaj2 New Member HowtoForge Supporter

    Further to this, I redownloaded the ispconfig tarball and ran the upgrade (reconfigure services) and it fixed them
    thanks for your help
     

Share This Page