Debian 9 Ispconfig 3.2.2 certbot-auto

Discussion in 'Installation/Configuration' started by rickbyronit, Jan 8, 2021.

  1. rickbyronit

    rickbyronit New Member HowtoForge Supporter

    System Debian 9
    ISPConfig Version: 3.2.2


    I have been following the following tutorial:
    https://www.howtoforge.com/tutorial...ovecot-ispconfig-3-1/2/#-install-lets-encrypt


    Instructions:
    11 Install Let's Encrypt

    ISPConfig 3.1 has support for the free SSL Certificate authority Let's encrypt. The Let's Encrypt function allows you to create free SSL certificates for your website from within ISPConfig.
    Now we will add support for Let's encrypt.

    Result:
    cd /usr/local/bin
    wget https://dl.eff.org/certbot-auto
    chmod a+x certbot-auto
    ./certbot-auto --install-only


    Running install:
    ./certbot-auto --install-only
    Skipping bootstrap because certbot-auto is deprecated on this system.
    Your system is not supported by certbot-auto anymore.
    Certbot cannot be installed.
    Please visit https://certbot.eff.org/ to check for other alternatives.


    Looking for suggestions of how to move forward.

    Thank you
     
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    You don't have to install it anymore as ISPConfig 3.2 comes with acme.sh and that will do the LE job for your server, so I think due to that you can safely skip that part.
     
    rickbyronit likes this.
  3. rickbyronit

    rickbyronit New Member HowtoForge Supporter

    Thank you Ahrasis,
    I have found acme.sh in /root.
    Working perfectly, have a gret evening.
     
    ahrasis likes this.

Share This Page