Debian 9 - IspConfig 3.1.11 - Sites - SSL , Let'sEncrypt

Discussion in 'ISPConfig 3 Priority Support' started by nmazza, Apr 30, 2018.

  1. nmazza

    nmazza Member

    Hello,
    I have closed all my CentOS servers, because, other Php versions on CentOS 7 not worked for me.
    Now, I installed my first Debian 9 , and in de ISPConfig Panel, under Sites
    SSL: lost the checked
    Let's Encrypt SSL: lost the checked

    When I enter in the sites, SSL and Let's Encrypt SSL, are in blank check.

    The ISPConfig, not working fine with that settings

    Ater the intallation,
    I only installed Php 7.1 and Php 7.2 follwing the guide
    https://www.howtoforge.com/tutorial/how-to-install-php-5.6-and-7.1-on-debian-9-stretch/
    Thanks
    Nestor Mazza
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is not related to the Debian 9 setup and ISPConfig is working pretty well with the settings made in that tutorial. The Let's encrypt and SSL option get's disabled when the domain name is not reachable from the server or when Let's encrypt fails to issue a SSL cert for it.

    Take a look here to find out why Let's encrypt is not able to issue a SSL cert for your domain:

    https://www.howtoforge.com/community/threads/lets-encrypt-error-faq.74179/
    https://www.faqforge.com/linux/debugging-ispconfig-3-server-actions-in-case-of-a-failure/
     
  3. nmazza

    nmazza Member

    Hello, Till
    Thanks, for your answer, the DNS systems, now actually on my Debian 9 and Let's Encrypt check box is working fine.
    Nestor Mazza
     

Share This Page