DEBIAN 9 - ISPCONFIG 3.1.10 - PHP 7.1 - PHP 7.2

Discussion in 'ISPConfig 3 Priority Support' started by sdesprez, Dec 30, 2017.

  1. sdesprez

    sdesprez New Member HowtoForge Supporter

    How to add in ISPCONFIG PHP 7.1 and PHP 7.2 with DEBIAN 9 under DEBIAN no problems ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There should be no problems with that. You can compile them e.g. in /opt and then add them to System > PHP versions in ISPConfig.
     
  3. sdesprez

    sdesprez New Member HowtoForge Supporter

    ./configure --prefix=/opt/php-7.1.12 --with-pdo-pgsql --with-zlib-dir --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib --with-gd --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --enable-exif --enable-bcmath --with-mhash --enable-zip --with-pcre-regex --with-pdo-mysql --with-mysqli --with-mysql-sock=/var/run/mysqld/mysqld.sock --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --with-openssl=/etc/ssl --with-fpm-user=www-data --with-fpm-group=www-data --with-libdir=/lib/x86_64-linux-gnu --enable-ftp --with-imap --with-imap-ssl --with-kerberos --with-gettext --with-xmlrpc --with-xsl --enable-opcache --enable-fpm

    --> error
    checking for RAND_egd... no
    checking for pkg-config... no
    configure: error: Cannot find OpenSSL's <evp.h>
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    try;

    apt-get install libssl-dev
     

Share This Page