Debian 8 to 9 HowTo and error messages

Discussion in 'Installation/Configuration' started by HitoDev, Jun 11, 2019.

  1. HitoDev

    HitoDev New Member

    Hello,
    Following the How to Upgrade Debian 8 (Jessie) to 9 (Stretch) safely HowTo (https://www.howtoforge.com/tutorial/how-to-upgrade-debian-8-jessie-to-9-stretch/) I encounter a number of problems during Debian 8 update step (Update the packages for Debian 8).
    The orignal /etc/apt/sources.list was:
    Code:
    #deb http://debian.mirrors.ovh.net/debian/ jessie main
    #deb-src http://debian.mirrors.ovh.net/debian/ jessie main
    
    #deb http://security.debian.org/ jessie/updates main
    #deb-src http://security.debian.org/ jessie/updates main
    
    # jessie-updates, previously known as 'volatile'
    #deb http://debian.mirrors.ovh.net/debian/ jessie-updates main
    #deb-src http://debian.mirrors.ovh.net/debian/ jessie-updates main
    
    # jessie-backports, previously on backports.debian.org
    #deb http://debian.mirrors.ovh.net/debian/ jessie-backports main
    #deb-src http://debian.mirrors.ovh.net/debian/ jessie-backports main
    
    #deb http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free
    #deb-src http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free
    
    And the updated for Debian 9 upgrade:
    Code:
    deb http://httpredir.debian.org/debian stretch main contrib non-free
    deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
    deb http://security.debian.org stretch/updates main contrib non-free
    
    And it's an ispConfig server
    ---------------------------------
    apt-get update
    ---------------------------------
    1/public key is not available: NO_PUBKEY

    Code:
    W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http: //dl.hhvm.com jessie InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B4112585D386EB94
    Resolved by adding the key:
    Code:
    [email protected]:/# sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B4112585D386EB94
    2/ IOError: [Errno 2] No such file or directory
    Code:
    Installing new version of config file /etc/mailman/apache.conf ...
    
    Traceback (most recent call last):
      File "/var/lib/mailman/bin/list_lists", line 134, in <module>
        main()
      File "/var/lib/mailman/bin/list_lists", line 101, in main
        mlist = MailList.MailList(n, lock=0)
      File "/var/lib/mailman/Mailman/MailList.py", line 131, in __init__
        self.Load()
      File "/var/lib/mailman/Mailman/MailList.py", line 703, in Load
        self.CheckVersion(dict)
      File "/var/lib/mailman/Mailman/MailList.py", line 753, in CheckVersion
        self.Lock()
      File "/var/lib/mailman/Mailman/MailList.py", line 162, in Lock
        self.__lock.lock(timeout)
      File "/var/lib/mailman/Mailman/LockFile.py", line 243, in lock
        self.__write()
      File "/var/lib/mailman/Mailman/LockFile.py", line 422, in __write
        fp = open(self.__tmpfname, 'w')
    IOError: [Errno 2] No such file or directory: '/var/lib/mailman/locks/mailman.lock.nsXXXXX.ip-xx-xx-xx.eu.22209.0'
    ---------------------------------
    apt-get dist-upgrade
    ---------------------------------

    During this step I choose N at each configuration question
    1/ dpkg: perl-modules: dependency problems
    Code:
    dpkg: perl-modules: dependency problems, but removing anyway as you requested:
     perl depends on perl-modules (>= 5.20.2-3+deb8u7).
     spamassassin depends on libarchive-tar-perl; however:
      Package libarchive-tar-perl is not installed.
      Package perl-modules which provides libarchive-tar-perl is to be removed.
     amavisd-new depends on libarchive-tar-perl; however:
      Package libarchive-tar-perl is not installed.
      Package perl-modules which provides libarchive-tar-perl is to be removed.
     libmailtools-perl depends on libnet-perl; however:
      Package libnet-perl is not installed.
      Package perl-modules which provides libnet-perl is to be removed.
    2/ dpkg warning about udev
    Code:
    dpkg: considering deconfiguration of ifupdown, which would be broken by installation of udev ...
    dpkg: yes, will deconfigure ifupdown (broken by udev)
    dpkg: considering deconfiguration of systemd, which would be broken by installation of udev ...
    dpkg: yes, will deconfigure systemd (broken by udev)
    3/ HHVM is being removed
    Do I need to run manually the commands?
    Code:
    ********************************************************************
    * HHVM is being removed. You can remove it from your webserver with: ---
    *
    * $ sudo /usr/share/hhvm/uninstall_fastcgi.sh
    * $ sudo /etc/init.d/nginx restart
    * $ sudo /etc/init.d/apache restart
    ********************************************************************
    
    4/ There is a MySQL server running, but we failed in our attempts to stop it.
    Code:
    There is a MySQL server running, but we failed in our attempts to stop it.
    Stop it yourself and try again!
    dpkg: error processing package mariadb-server-10.0 (--remove):
     subprocess installed pre-removal script returned error exit status 1
    dpkg: mariadb-client-10.0: dependency problems, but removing anyway as you requested:
     mariadb-server-10.0 depends on mariadb-client-10.0 (>= 10.0.30-0+deb8u2); however:
      Package mariadb-client-10.0 is to be removed.
     roundcube-mysql depends on mariadb-client | mysql-client | virtual-mysql-client; however:
      Package mariadb-client is not configured yet.
      Package mysql-client is not installed.
      Package virtual-mysql-client is not installed.
      Package mariadb-client-10.0 which provides virtual-mysql-client is to be removed.
    
    Removing mariadb-client-10.0 (10.0.30-0+deb8u2) ...
    Removing mariadb-client-core-10.0 (10.0.30-0+deb8u2) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Errors were encountered while processing:
     mariadb-server-10.0
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    At this step I decided to stop everything :eek:
    Usually, what is the right process to follow to continue the upgrade, in this case ?
    Need I stop MySQL and run again apt-get dist-upgrade ?
    Help welcome !
     
    Last edited: Jun 12, 2019
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Debian project provides upgrading instructions in the Release Notes:
    https://www.debian.org/releases/stable/releasenotes
    Use those to solve problems during the upgrade process.
    There is this, for instance: https://www.debian.org/releases/stable/amd64/release-notes/ch-upgrading.en.html#unofficial-sources
    You seem to have HHVM installed from outside of Debian. Are there still files in /etc/apt/sources.list.d/ ?
    You should remove packages installed from outside of Debian Jessie before the upgrade to Stretch.
     
  3. HitoDev

    HitoDev New Member

    Thank you for your reply.
    thne I guess I have to uninstall HHVM, stop MySQL server then run again apt-get update & apt-get dist-upgrade, isn'it ?
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    More or less, but the Debian Upgrade instructions recommend doing the upgrade in two phases, that is first
    Code:
    apt-get update
    apt-get upgrade
    and then
    Code:
    apt-get dist-upgrade
    Plus, remove the files in /etc/apt/sources.list.d/ before update, so things there do not mess up the upgrade.
    I have never stopped MySQL before the upgrade, but you should first fix the errors you have now in Jessie and only then attempt the upgrade to Stretch. Or if MySQL stays faulty, uninstall it, then do the upgrade and install it back when Stretch is running.
     
  5. HitoDev

    HitoDev New Member

    OK, in fact it appears the described problems occured during the 8 to 9 upgrades, not during Debian 8 upgrade (I corrected my post).
    /etc/debian_version returns 9.9

    dpkg --audit returns:
    Code:
    The following packages have been unpacked but not yet configured.
    They must be configured using dpkg --configure or the configure
    menu option in dselect for them to work:
     apache2              Apache HTTP Server
     apache2-bin          Apache HTTP Server (modules and other binary files)
     apache2-data         Apache HTTP Server (common files)
     apache2-utils        Apache HTTP Server (utility programs for web servers)
     apt                  commandline package manager
     apt-utils            package management related utility programs
     dmeventd             Linux Kernel Device Mapper event daemon
     guile-2.0-libs:amd64 Core Guile libraries
     ifupdown             high level tools to configure network interfaces
     imagemagick          image manipulation programs -- binaries
     imagemagick-6.q16    image manipulation programs -- quantum depth Q16
     libalgorithm-diff-xs-perl module to find differences between files (XS acceler
     libapache2-mod-passenger Rails and Rack support for Apache2
     libaprutil1:amd64    Apache Portable Runtime Utility Library
     libaprutil1-dbd-sqlite3:amd64 Apache Portable Runtime Utility Library - SQLite3 Driv
     libaprutil1-ldap:amd64 Apache Portable Runtime Utility Library - LDAP Driver
     libapt-inst2.0:amd64 deb package format runtime library
     libasprintf-dev:amd64 GNU Internationalization library development files
     libasprintf0v5:amd64 GNU library to use fprintf and friends in C++
     libb-hooks-op-check-perl Perl wrapper for OP check callbacks
     libbareword-filehandles-perl Perl pragma to disable bareword filehandles
     libberkeleydb-perl   use Berkeley DB databases from Perl
     libc-dev-bin         GNU C Library: Development binaries
     libc-l10n            GNU C Library: localization files
     libc6-dev:amd64      GNU C Library: Development Libraries and Header Files
     libclass-xsaccessor-perl Perl module providing fast XS accessors
     libclone-perl        module for recursively copying Perl datatypes
     libconvert-uulib-perl Perl interface to the uulib library (a.k.a. uudeview/uue
     libcrypt-openssl-bignum-perl Perl module to access OpenSSL multiprecision inte
     libcrypt-openssl-rsa-perl module for RSA encryption using OpenSSL
     libcurl3:amd64       easy-to-use client-side URL transfer library (OpenSSL fla
     libdbd-mysql-perl    Perl5 database interface to the MariaDB/MySQL database
     libdbi-perl          Perl Database Interface (DBI)
     libdevmapper-event1.02.1:amd64 Linux Kernel Device Mapper event support library
     libfile-fcntllock-perl Perl module for file locking with fcntl(2)
     libgnutls30:amd64    GNU TLS library - main runtime library
     libgssapi-perl       Perl extension providing access to the GSSAPIv2 library
     libhogweed4:amd64    low level cryptographic library (public-key cryptos)
     libhtml-parser-perl  collection of modules that parse HTML text documents
     libicu57:amd64       International Components for Unicode
     libidn2-0:amd64      Internationalized domain names (IDNA2008) library
     libindirect-perl     module warning about using the indirect object syntax
     libkyotocabinet16v5:amd64 Straightforward implementation of DBM - shared library
     libldap-2.4-2:amd64  OpenLDAP libraries
     libldap-common       OpenLDAP common files for libraries
     liblexical-sealrequirehints-perl Perl module to prevent the leakage of lexical
     liblocale-gettext-perl module using libc functions for internationalization in
     liblua5.2-0:amd64    Shared library for the Lua interpreter version 5.2
     liblvm2app2.2:amd64  LVM2 application library
     liblvm2cmd2.02:amd64 LVM2 command library
     libmailutils5:amd64  GNU Mail abstraction library
     libmariadbclient18:amd64 MariaDB database client library
     libmultidimensional-perl Perl pragma to disable multidimensional array emulati
     libnet-libidn-perl   Perl bindings for GNU Libidn
     libnet-ssleay-perl   Perl module for Secure Sockets Layer (SSL)
     libnetaddr-ip-perl   IP address manipulation module
     libnettle6:amd64     low level cryptographic library (symmetric and one-way cr
     libnghttp2-14:amd64  library implementing HTTP/2 protocol (shared library)
     libparams-classify-perl Perl module for argument type classification
     libpcre16-3:amd64    Old Perl 5 Compatible Regular Expression Library - 16 bit
     libpcre3-dev:amd64   Old Perl 5 Compatible Regular Expression Library - develo
     libpcre32-3:amd64    Old Perl 5 Compatible Regular Expression Library - 32 bit
     libpcrecpp0v5:amd64  Old Perl 5 Compatible Regular Expression Library - C++ ru
     libperl5.24:amd64    shared Perl library
     libpsl5:amd64        Library for Public Suffix List (shared libraries)
     libpython2.7:amd64   Shared Python runtime library (version 2.7)
     libpython2.7-dev:amd64 Header files and a static library for Python (v2.7)
     libpython2.7-minimal:amd64 Minimal subset of the Python language (version 2.7)
     libpython2.7-stdlib:amd64 Interactive high-level object-oriented language (standard
     libpython3-stdlib:amd64 interactive high-level object-oriented language (default
     libpython3.5-stdlib:amd64 Interactive high-level object-oriented language (standard
     libreadline7:amd64   GNU readline and history libraries, run-time libraries
     librtmp1:amd64       toolkit for RTMP streams (shared library)
     libruby2.3:amd64     Libraries necessary to run Ruby 2.3
     libsasl2-2:amd64     Cyrus SASL - authentication abstraction library
     libsocket6-perl      Perl extensions for IPv6
     libssl1.0.2:amd64    Secure Sockets Layer toolkit - shared libraries
     libsub-name-perl     module for assigning a new name to referenced sub
     libterm-readkey-perl perl module for simple terminal control
     libtext-charwidth-perl get display widths of characters on the terminal
     libtext-iconv-perl   converts between character sets in Perl
     libunix-syslog-perl  Perl interface to the UNIX syslog(3) calls
     libuv1:amd64         asynchronous event notification library - runtime library
     libxml2:amd64        GNOME XML library
     locales              GNU C Library: National Language (locale) data [support]
     lvm2                 Linux Logical Volume Manager
     mailutils            GNU mailutils utilities for handling mail
     mailutils-common     Common files for GNU mailutils
     mariadb-client       MariaDB database client (metapackage depending on the lat
     mariadb-server       MariaDB database server (metapackage depending on the lat
     passenger            Rails and Rack support
     perl                 Larry Wall's Practical Extraction and Report Language
     perl-modules-5.24    Core Perl modules
     perl-openssl-defaults:amd64 version compatibility baseline for Perl OpenSSL packages
     postfix              High-performance mail transport agent
     postfix-mysql        MySQL map support for Postfix
     postfix-sqlite       SQLite map support for Postfix
     python2.7            Interactive high-level object-oriented language (version
     python2.7-dev        Header files and a static library for Python (v2.7)
     python2.7-minimal    Minimal subset of the Python language (version 2.7)
     python3              interactive high-level object-oriented language (default
     python3.5            Interactive high-level object-oriented language (version
     rake                 ruby make-like utility
     ruby                 Interpreter of object-oriented scripting language Ruby (d
     ruby-did-you-mean    smart error messages for Ruby > 2.3
     ruby-minitest        Ruby test tools supporting TDD, BDD, mocking, and benchma
     ruby-net-telnet      telnet client library
     ruby-passenger       transitional dummy package for passenger
     ruby-power-assert    library showing values of variables and method calls in a
     ruby-test-unit       unit testing framework for Ruby
     ruby2.3              Interpreter of object-oriented scripting language Ruby
     udev                 /dev/ and hotplug management daemon
    
    The following packages have been triggered, but the trigger processing
    has not yet been done.  Trigger processing can be requested using
    dselect or dpkg --configure --pending (or dpkg --triggers-only):
     ufw                  program for managing a Netfilter firewall
    
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Quite a mess. I would restore the Jessie system and start upgrade process again, this time following the Release Notes upgrade instructions.
    If you prefer not doing that, the dpkg--audit suggest how to get the configurations done. You might get lucky and sort out the mess.
     

Share This Page