Debian 7 / GD library issue

Discussion in 'Installation/Configuration' started by aldo, Jan 23, 2011.

  1. aldo

    aldo Member HowtoForge Supporter

    Installing Drupal 7 in a ISPconfig3 site I get this error in Drupal 7 Status Report:

    Error GD library rotate and desaturate effects 2.0 or higher
    The GD Library for PHP is enabled, but was compiled without support for functions used by the rotate and desaturate effects. It was probably compiled using the official GD libraries from http://www.libgd.org instead of the GD library bundled with PHP. You should recompile PHP --with-gd using the bundled GD library. See the PHP manual.

    Last time I installed the right version of GD library from dotdeb.org (as here described http://drupal.org/node/465264) I have irreparably destroyed my Debian 5 lenny + ISPconfig3 installation.

    Can you help me to solve this GD library issue on my fresh installation?

    Thank you in advance for any help.
     
    Last edited: Apr 26, 2011
  2. aldo

    aldo Member HowtoForge Supporter

    Obviously could not be Debian 7, it was Drupal 7.

    I solved by deleting a repository (suggested in another forum) and reinstalling PHP.
     

Share This Page