debian (64nit) ispconfig 3

Discussion in 'Installation/Configuration' started by DataVampire, Jul 2, 2010.

  1. DataVampire

    DataVampire New Member

    After many many probelms with different flavours of linus and isp config 3. i have finaly manged to do have a semi decent setup.

    Im nearly there in having a working server, i have a few problems but i think its best to tackle one by one.

    I, trying to make the problem as clear as possible to hopefuly get a speedy fix.

    ipconfig used - - ISPConfig
    operating sytem - Debian lenny 5 (64bit)
    Install used ---
    Problem : accsessing the controle panel from iether ip address or domain name.

    So i have installed isp config using the above method im pretty sure i followed it 100%, the install went smoothe no problmes or errors that i could see.

    the only way currently i can accses my controle panel is via my intermal ip ie

    i cannot use my external ip for example
    i cannot use any of my two domain names


    So in other words i can only accsess the panel via the lan.
    Has anyone got any ideas please.

    Thank you
  2. damir

    damir New Member

    First you need to portforward WAN ip to your local ip and open 8080 port in your router. Than you should be able to type in WAN ip followed by :8080. ISPC should show up now.

    If you want it to access by domain name dan you should set up A record that goes to your WAN ip: IN A
    www IN A

    These settings are done in your domain providers control panel.
  3. DataVampire

    DataVampire New Member

    OK thank you fo rhte post.

    The controle panel is working fine, bar the accses of the panel,

    as i siad above it works perfectly on internal ip of

    if it was a port problem i would not be able to reach it there.

    Doamin name again is working, it has populated nps there.
  4. falko

    falko Super Moderator ISPConfig Developer

    As damir said, make sure that your router forwards port 8080 to your ISPConfig server. If it still doesn't work, please ask your provider if they block port 8080.
  5. DataVampire

    DataVampire New Member

    Thank you Falko.

    LEts get a few things straight

    My router

    all ports are forwarded
    Firewall is turned off atm
    Dmz created for make a difference, firewall is off)

    My isp

    My isp is a pasive isp meanign they do nto blcok any ports

    results from

    Port Number: Port 8080 is Open

    I also now have another problem wich is now getting anoying, ie my domain name is now not showing up, after i deleted all users all wedbsites all domain names and reocrds i readded them, now im getting nothing zada nowt.

    If you do a

    it shows up two errors at the bottom


    MX Records Oh well, I did not detect any MX records so you probably don't have any and if you know you should have then they may be missing at your nameservers!


    WWW A Record ERROR: I could not get any A records for!

    (I only do a cache request, if you recently added a WWW A record, it might not show up here.)

    i have included screenshots of the ispconfig dns records ect,can you spot anything obvious?

    Thank you

    Attached Files:

  6. falko

    falko Super Moderator ISPConfig Developer

  7. DataVampire

    DataVampire New Member

    Attached Files:

  8. damir

    damir New Member

    You need to add a A record for ns1.
  9. DataVampire

    DataVampire New Member

    Hi i had already tried that see enclosed screenie

    Attached Files:

  10. damir

    damir New Member

    Have you port forwarded DNS port (53) (tcp and udp) in your router?
  11. DataVampire

    DataVampire New Member

    no need to, i have turned offf my routers firewall, and i have created a dmz zone for my server.

    aee atached screenie, im lost i dunno what else to try bar a new format

    Attached Files:

  12. damir

    damir New Member

    Your ns1 and ns2 answers correctly now so that is good. Although SKULL-AND-BONEZ.COM and WWW.SKULL-AND-BONEZ.COM have no records setup. No A record for SKULL-AND-BONEZ.COM.

    I can't get any answer with dig A SKULL-AND-BONEZ.COM or with dig @ns1.SKULL-AND-BONEZ.COM A SKULL-AND-BONEZ.CO
  13. DataVampire

    DataVampire New Member

    hmmmz i just did dig

    here it is below i think it is wrong

    should the server ip not be and not my gateway ip ?
    the server ip is
    my gateway ip is
    im usre my name servers should not be these also

    Attached Files:

    Last edited: Jul 6, 2010
  14. falko

    falko Super Moderator ISPConfig Developer

    I guess you have your router IP in /etc/resolv.conf which is fine as routers act as DNS servers for computers in the local network.
  15. DataVampire

    DataVampire New Member

    Ok im lost i ahve tried everything i possibly can.

    It was working semi ok until i deleted clients/domains ect ect to start again a fresh, wich i had not of bothered now. i guess another formatts to see if that helps.

    Thanks for trying to help though guys

Share This Page