Debian 64bits + Postfix + no-ip.org

Discussion in 'Installation/Configuration' started by essex, Dec 26, 2010.

  1. essex

    essex New Member

    Hello guys

    Merry Xmas 2 u all :)

    I have been searching a step by step postfix + no-ip.org example all over the internet and I can not find a single that goes to the end and works fine.

    I am still optmistic that anyone in here could gimme some help.

    Thanks a lot.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. essex13

    essex13 New Member

    Postfix emails --> Thunderbird or Outlook Express

    Hi there, thank you for you assistence.

    I just want to read these emails and to send others through "thunderbird" or "Outlook express" - send e receive emails. Thank you


    Logs do postfix

    # tail -f /var/log/mail.log
    Dec 26 22:03:15 debian postfix/master[6708]: daemon started -- version 2.5.5, configuration /etc/postfix
    Dec 26 22:03:27 debian pop3d: Connection, ip=[::ffff:127.0.0.1]
    Dec 26 22:03:41 debian pop3d: LOGIN FAILED, user=usuario2, ip=[::ffff:127.0.0.1]
    Dec 26 22:07:06 debian pop3d: Connection, ip=[::ffff:127.0.0.1]
    Dec 26 22:07:19 debian pop3d: LOGIN FAILED, user=usuario2, ip=[::ffff:127.0.0.1]
    Dec 26 22:08:54 debian pop3d: Connection, ip=[::ffff:127.0.0.1]
    Dec 26 22:09:11 debian pop3d: LOGIN FAILED, user=usuario1, ip=[::ffff:127.0.0.1]
    Dec 26 22:09:29 debian pop3d: LOGIN FAILED, user=conta, ip=[::ffff:127.0.0.1]
    Dec 26 22:09:41 debian pop3d: LOGOUT, ip=[::ffff:127.0.0.1]
    Dec 26 22:09:41 debian pop3d: Disconnected, ip=[::ffff:127.0.0.1]


    # cat /home/usuario2/Maildir/new 1293417224.V804I3ca008M705366.debian

    # cd /home/usuario2/Maildir/new

    # cat /home/usuario2/Maildir/new/1293417224.V804I3ca008M705366.debian
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Try this guide: http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-debian-lenny

    But remember, as you are using dynamic IP addresses, to set up relaying. Also, you should get subdomains from dyndns.org or no-ip that you use for your email addresses (like user@sub.dyndns.org). The MX record must point to your public IP address.
    If you use your own domains for your email addresses, you must change the MX record whenever your IP changes which will cause problems; therefore, get a subdomain from dyndns.org or no-ip.
     
  5. essex13

    essex13 New Member

    no-ip.org + outlook express

    Hi Falko,

    Thanks a lot for your reply. Please take a look below at the configuration.

    Perhaps u could gimme some hints.

    Thanks again.

    J.P.

    ================================================

    ewbhome.no-ip.org

    ================================================

    dns ( setup up ok )


    dig ewbhome.no-ip.org

    :
    :
    ;; ADDITIONAL SECTION:
    nf1.no-ip.com. 86397 IN A 204.16.252.8
    nf2.no-ip.com. 86397 IN A 69.72.255.8
    nf3.no-ip.com. 86397 IN A 69.65.40.108
    nf4.no-ip.com. 3597 IN A 69.65.5.122

    ;; Query time: 0 msec
    ;; SERVER: 192.168.2.1#53(192.168.2.1)
    ;; WHEN: Sun Jan 2 11:40:35 2011
    ;; MSG SIZE rcvd: 196


    =================================================

    # ifconfig eth0

    eth0 Link encap:Ethernet HWaddr 90:e6:ba:dc:02:8b
    inet addr:192.168.100.70 Bcast:192.168.100.255 Mask:255.255.255.0
    inet6 addr: fe80::92e6:baff:fedc:28b/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:188655 errors:0 dropped:0 overruns:0 frame:0
    TX packets:205870 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:45632660 (43.5 MiB) TX bytes:29160688 (27.8 MiB)
    Interrupt:252 Base address:0xc000

    # ifconfig eth1

    eth1 Link encap:Ethernet HWaddr 00:e0:7d:eb:fa:6d
    inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::2e0:7dff:feeb:fa6d/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:200794 errors:0 dropped:0 overruns:0 frame:0
    TX packets:177838 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:28036125 (26.7 MiB) TX bytes:29427450 (28.0 MiB)
    Interrupt:19 Base address:0xec00

    =================================================

    # route -n

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.100.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    0.0.0.0 192.168.100.1 0.0.0.0 UG 0 0 0 eth0

    =================================================

    # nano /etc/network/interfaces

    # -----------------[ begin: interfaces file ]----------------------------------------------
    auto lo
    iface lo inet loopback
    allow-hotplug eth0

    iface eth0 inet static
    address 192.168.100.70 # TPA ip ( provedor local )
    netmask 255.255.255.0
    network 192.168.100.0
    broadcast 192.168.100.255
    gateway 192.168.100.1 # TPA gateway
    dns-search ewb
    #----------------------------------------------------------
    allow-hotplug eth1
    iface eth1 inet static
    address 192.168.2.1 # any ip
    netmask 255.255.255.0
    network 192.168.2.0
    broadcast 192.168.2.255
    dns-nameservers 192.168.2.1 # any ip

    # -----------------[ end: interfaces file ]----------------------------------------------

    =================================================

    ===[ eth0 ]===

    ifonfig eth0 up
    ifconfig eth0 192.168.100.70 255.255.255.0
    route add deafult gw 192.168.100.1


    # nano /etc/resolv.conf

    nameserver 8.8.8.8
    nameserver 8.8.6.6


    ===[ eth1 ]===

    ifonfig eth1 up
    ifconfig eth1 192.168.2.1 netmask 255.255.255.0

    echo 1 >/proc/sys/net/ipv4_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE


    eth1 plugar no meu notebook
    ifconfig eth1 192.168.2.1 netmask 255.255.255.0

    route add deafult gw 192.168.100.1

    ==============================================

    # nano /etc/resolv.conf

    nameserver 8.8.8.8
    nameserver 8.8.6.6

    =============================================

    # nano /etc/apt/sources.list

    # My notes
    # nano /etc/apt/sources.list

    #---[ begin: sources.list ]-------------------------------------------------

    deb http://debian.pop-sc.rnp.br/debian/ lenny main
    deb-src http://debian.pop-sc.rnp.br/debian/ lenny main
    deb-src http://security.debian.org/ lenny/updates main
    deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
    #---[ end ]---------------------------------------------------------------------


    ping ewbhome.no-ip.org

    PING ewbhome.no-ip.org (187.85.174.7) 56(84) bytes of data.
    64 bytes from wldin174-07.tpa.net.br (187.85.174.7): icmp_seq=1 ttl=64 time=0.554 ms
    64 bytes from wldin174-07.tpa.net.br (187.85.174.7): icmp_seq=2 ttl=64 time=0.588 ms
    64 bytes from wldin174-07.tpa.net.br (187.85.174.7): icmp_seq=3 ttl=64 time=0.569 ms
     
  6. essex13

    essex13 New Member

    Hi

    Hi

    Any tip, please.

    Thanks
     
  7. essex13

    essex13 New Member

    Hello there


    As there is no answer... do me a favor please...

    "erase my post"


    Tks
     
  8. pititis

    pititis Member

    You don't have MX record for your domain. Set it in the no-ip panel.

    Cheers!
     

Share This Page