Debian 6 - Roundcube 0.3.1 HTML problem

Discussion in 'Server Operation' started by erosbk, Apr 18, 2011.

  1. erosbk

    erosbk New Member

    Hello all,

    This is my first post, first and after all, I want to thank you for all your work and this bible of information, mantained for all the staff and users. I hope in a near future, be capable of help others as you will help me!

    (I beg your pardon for my poor english :p)

    This is my problem. I have installed a multiserver setup in Debian Squeeze with ISPConfig 3 (last version), using roundcube (I can paste the installation script of the webserver if you think it can help with the troubleshoting).

    The problem is with HTML mail. If I send an email in HTML, no matter which program I use to read it, it shows in PLAIN TEXT (I can see the HTML tags)

    If I see the Sent mail, I see it en PLAIN TEXT too... I don't know what is happening, I tried to google for information about this without luck...

    Example:

    <p><strong><span style="text-decoration: underline;"><em>testing
    xD</em></span></strong></p>

    Thank you very much in advance!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If you send HTML mails with a "normal" email client such as Outlook or Thunderbird, it is working?
     
  3. erosbk

    erosbk New Member

    Tested.

    1) HTML Mail sent from Outlook
    - I can see ok it with both Roundcube and Oultook
    2) HTML Mail sent from Rouncube
    - I can't see it as HTML in both Roundcube and Outlook. It is plain text (I can see the HTML tags...)

    Could ir be a PHP problem instead Roundcube? thanks for your help. I am using the last stable version of Roundcube for Debian Squeeze.
     
  4. erosbk

    erosbk New Member

    Ok, I have news about this...

    If I set in "settings" Compose in HTML, it works perfectly. If I start a "text" mail and change to HTML, it would be send as "text showing html tags".

    If a mail started as HTML and is changed to text, and next again to HTML, the problem is the same.

    I think that the Debian package 0.3.1 has a bug with the function HTML/text mode mail...

    Maybe installing and updated version of Roundcube could fix this... but I think I will wait for the next release of the package in debian...
     
  5. abu.hurayra

    abu.hurayra New Member

    You shouldn't wait for an update I installed roundcube v0.5.1 from squeeze backports and it didn't fix the bug

    I applied this Temporary fix : Making html editor open by default

    Code:
    vi /etc/roundcube/main.inc.php
    and make this line like this to use html by default :
    Code:
    $rcmail_config['htmleditor'] = 1;
    With what you found out erosbk, it seems there is a bug into the editor switcher from plain text to html, I don't really have time to look into that.

    If you find out the real solution, please let me know.

    Thanks
     

Share This Page