Debian 6 and PHP7.1

Discussion in 'Server Operation' started by mphayesuk, Oct 16, 2017.

  1. mphayesuk

    mphayesuk Member

    Hi all, I know this is an old version of Debian but my previous attempts to upgrade to Debian 7 failed.

    So I have been following this guide https://www.howtoforge.com/tutorial/how-to-install-php-7-on-debian/ but on my system the first error on configure is that the openssl version is not good enough but I am unable to apt-get anything higher than 0.9.8. Does anyone know how I can get around/fix this error so I can install PHP7.1.

    Thanks
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    well you need to compile other dependencies aswell like openssl.
    If you want curl with your PHP 7.1 and curl shall support openssl, compile curl to be used for PHP 7.1 and so on.
     
  3. HSorgYves

    HSorgYves Active Member

    We are at Debian 9(.2) aka Stretch. LTS for Debian 6 ended February 2016, you should really consider upgrading and you should even consider doing so urgently if you do not want your server to get hacked sooner or later.
     

Share This Page