Debian 4

Discussion in 'Installation/Configuration' started by alejandrowa, Apr 9, 2007.

  1. alejandrowa

    alejandrowa New Member

  2. falko

    falko Super Moderator ISPConfig Developer

  3. alejandrowa

    alejandrowa New Member

    etch

    thanks! fast response.. :D
     
  4. bitonw

    bitonw New Member

    i just upgraded my system from sarge to etch, result...

    no mysql
    no apache 2

    i'm trying to get every thing up & running again...

    mysql -> added old_password = 1

    still no apache (web sites down)
     
  5. mccharlet

    mccharlet Member HowtoForge Supporter

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check your logs for error messages and post them here.

    The updates ahs most likely overwritten some config files.
     
  7. bitonw

    bitonw New Member

    i'm trying to get some logs to analis them. it looks like that the configs are messed up. the ipsconfig was running on port 80 & 443... solved that


    got this in the web browser when try to connect to ISPConfig

    Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60

    this is from apache2 log:
    [Mon Apr 09 15:19:18 2007] [notice] caught SIGTERM, shutting down
    [Mon Apr 09 15:20:51 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Apr 09 15:20:54 2007] [notice] Apache/2.2.3 (Debian) PHP/4.4.4-8+etch1 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_perl/2.0.2 Perl/v5.8.8 configured -- resumi$[Mon Apr 09 15:31:42 2007] [notice] caught SIGTERM, shutting down
    [Mon Apr 09 15:33:07 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Apr 09 15:33:10 2007] [notice] Apache/2.2.3 (Debian) PHP/4.4.4-8+etch1 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_perl/2.0.2 Perl/v5.8.8 configured -- resumi$[Mon Apr 09 16:56:11 2007] [notice] SIGHUP received. Attempting to restart
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs
    unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d':$Unable to open logs

    got ISPConfig running on port 81 but only on http. version message...

    SPConfig
    Version: 2.2.9
    (c) ISPConfig 2007

    so that wrong too...
     
    Last edited: Apr 9, 2007
  8. bitonw

    bitonw New Member

    web sites still down...

    managed to get cronolog back in /root/ipsconfig... apache2 now running but on default page so no (virtual) web sites...
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that the Vhost_ispconfig.conf file is still included in your apache configuration. The update might have removed it. Check if the updates has made a copy of your apache2.conf file where you might copy the ISPConfig part from.

    You installed a new mysql version which is not supported by the php mysql xriver. Install the libmysqlclient15-dev package and the download the latest ISPConfig package and run setp to update ISPConfig and recompile PHP.
     
  10. bitonw

    bitonw New Member

    can some one pls tell me witch of the 2 httpd.conf i can copy over the httpd.conf?

    /root/ispconfig/http/conf

    httpd.conf_http
    or
    httpd.conf_https

    thx,
    bt
     
  11. bitonw

    bitonw New Member

    Vhost_ispconfig.conf still in apache2 config web sites up and running :D

    already did install libmysqlclient15-dev (apt-get install mysql-server mysql-client libmysqlclient15-dev) since i took parts from the perfect etch setup... :)

    the only issue i have is ISPConfig... it's giving now:

    Could not establish an encrypted connection because certificate presented by xxx.xxx.xxx.xxx is invalid or corrupted. Error Code: -8182

    when trying to connect via port 81
     
  12. bitonw

    bitonw New Member

    reinstalling ISPConfig 2.2.11

    checked all settings according the perfect etch setup and are reinstalling ISPConfig 2.2.11.
     
  13. bitonw

    bitonw New Member

    looking good after reinstall of ISPConfig.

    thanks for all help folks! :cool:
     

Share This Page