Debian 3.1 to 4.0 Upgrade with ISPC

Discussion in 'Installation/Configuration' started by PoleCat, Apr 18, 2008.

  1. PoleCat

    PoleCat New Member

    Is it possible to upgrade a Debian 3.1 system to Debian 4.0 with a live ISPC system on it? Will ISPC work fine afterwards or does it need a re-install?

    Has anyone done this? Else is there is tutorial on steps to follow to ensure a smooth upgrade?

  2. t-mug

    t-mug New Member

    Should work

    I did this in a vitual machine with the old Sarge-ISPconfig VMware Appliance and it worked in general. But any selfcompiled stuff will break and some service configs seemed to be broken. So I had an issue with enabled suphp and apache denies to start after upgrade. Another thing was, that apache2.conf was overwritten and the vhostconfig was'nt included after the upgrade. I gave up at a certain point because I noticed that this old VMware image is not a standard Perfect ISP setup. But if you are familiar with stuff like trouble shooting on linux systems, go ahead. The upgrade in genaral worked well, all service configs have to be reviewed to work further together with ISPconfig.

    Maybe it is more effective to make a new OS install, then ISPconfig Install and reimport the saved db and special sections of passwd and so on. I guess, this would be my way rather than playing around with nonworking stuff after the upgrade.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    An update of the debian perfect setup guide to the next version works relatively well (the vmware image is another thing as t-mug pointed out). What you should do is that you make a backup copy of all files in /etc in case some config file sections get overwritten. After updating your system with apt or synaptic or whatever package manager frontend you prefer, you should go trough every step of the debian 4.0 perfect setup guide and compare your config files with the settings described in the guide. If I rememebr correctly, some options in the sasl configuration file has been renamed. The remainings etup should work.
  4. PoleCat

    PoleCat New Member

    Just to get back about how the upgrade went from 3.1 to 4.0.

    *In the words of Borat* "Great Success!"

    Was real easy, just changed the apt sources to etch and the amd64 packages updated as well, even though there was no config needed in apt to select amd64.

    apt-get update
    apt-get dist-upgrade

    Rebooted, reinstalled ISPC, found mysql 4.1 was not available for debian 4.0, had to upgrade to 5.0, removed and purged the config packages for mysqlclient and libraries for 4.1.
    Had to then recompile ISPC again as it was using the 4.1client libraries. After that tested everything, it all works.

    Thanks for the help guys. ;)

Share This Page