Debian 11 and higher

Discussion in 'Installation/Configuration' started by Mike Hosken, Sep 18, 2021.

  1. Mike Hosken

    Mike Hosken New Member

    I’ve noticed the the latest update to ispconfig supports Debian 11. Excellent work. Is there any install or upgrade instructions available. I looked at the manual and it only talks about Debian 8. If I buy another manual would it cover the latest version of Debian Install directions. Thanks very much
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no install guides for Debian 11 available yet. We are working on an update.
     
    Mike Hosken likes this.
  3. Mike Hosken

    Mike Hosken New Member

    Thanks very very much. Appreciate the efforts.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Btw. The ISPConfig auto-installer is capable of installing ISPConfig on Debian 11 already. I've just updated the guide to reflect that. The auto-installer is the preferred installation method now anyways.

    https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/

    Nonetheless, the traditional 'Perfect Server' guide for Debian 11 will follow soon as well.
     
  5. Mike Hosken

    Mike Hosken New Member

    Thanks very much for your efforts. I’ve been using ispconfig for over 12 years and haven’t looked back. I need the perfect server to install a couple of my servers, I have to compile packages also. I’ve had ispconfig working on hppa-parisc Debian port and never had an issue with it.
     
    till likes this.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use the current Debian 10 perfect server guides as the basis too, there are not so many differences:

    - Mailman is not available, leave it out.
    - getmail4 package is now just getmail.
    - webalizer is not available anymore, leave it out.
    - goaccess can be installed like this now: apt -y install goaccess
    - phpmyadmin can be installed with: "apt-get install phpmyadmin" again.
    - When it comes to installing PHP packages, the version number is now 7.4

    This would be the exact Debian 10 to 11 port. The new guides that I'm working on will be a bit different though as we've modernized the setup. The new guides will use apache event mpm instead of prefork to get http2 support, remove mod_php and use php-fpm for phpmyadmin and roundcube instead, and switch from Amavis to rspamd.
     
  7. Mike Hosken

    Mike Hosken New Member

    Thanks very much, I’ll start an install tomorrow and let you know how it goes.

    why is mailman not included in repo or not supported?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Mailman 2 is not in Debian repo anymore and Mailman 3 is very different and therefore not working with the Mailman 2 implementation in ISPConfig. So you can use Mailman on Debian 11 in ISPConfig, but you will have to find a way to install the (classic) Mailman 2 e.g. from source or by installing a package from Debian 10.
     
  9. Mike Hosken

    Mike Hosken New Member

    Perfect for me I build a stable hybrid for these machines and put in their own repo. Then I update it for change or security fixes. It’s effectively an ispconfig Debian based Linux.
    I’m happy to produce a Debian based ispconfig Linux that contains all the software and management tools needed for running an ispconfig server. I’ve done this previously for HPPA. Amd64 i386 you can even get the installer to install everything you need and run a config script. You simply boot from the media and ISP gets installed with the rest of the os. Config script gets added to the installer file and your CD. Download It, add to UII or write to a CD or DVD and install it. Log into the the newly installed machine and start the installer. Would people want something like this done, As I’m more than interested in making this happen
    Let me know if this is something that would help and be useful.
     
    till, Farsus and ahrasis like this.
  10. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Indeed that will be helpful and useful if you share them with the community.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    I think that any additional way which makes it easier to install ISPConfig is helpful :)
     
  12. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Just as info, the version of goaccess in the Debian repo does not work with ISPConfig, the version is too old.

    phpMyAdmin can be best installed from source and kept up to date using https://www.howtoforge.com/communit...-installation-up-to-date-automatically.88495/
     
    till likes this.
  13. ledufakademy

    ledufakademy Member HowtoForge Supporter

    we need mailman (mailing list tool her), after upgrade from debian 10 to 11 mailman not working , what must we do in order to have mailman working again ?
    any ideas would be appreciate :(
     
  14. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Mailman3 is not (yet) supported by ISPConfig and mailman2 is not available on Debian 11. There is no fix currently.
     
  15. ledufakademy

    ledufakademy Member HowtoForge Supporter

    ouch ... :confused:
    ok , we must found an alternative do you have any idea ?
    install mailman3 (or something else) on another server, and setup this tool in order to work with ISPCOnfig mail server ?
    So mailman3 is being the next release that will be in ISPConfig ?
     
    Last edited: Mar 8, 2022
  16. gscaglia

    gscaglia Member HowtoForge Supporter

    Till proposed these solutions a few posts above:
     

Share This Page