Debian 10 Perfect Server - issues with phpmyadmin

Discussion in 'ISPConfig 3 Priority Support' started by curiousadmin, May 2, 2020.

  1. curiousadmin

    curiousadmin New Member HowtoForge Supporter

    Hello Fellow Admins.
    I installed my server using this guide: The Perfect Server - Debian 10 (Buster) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1
    And everything seem to be working except I'm getting following error on login to https://myserver.com:8080/phpmyadmin
    Code:
    mysqli_real_connect(): (HY000/1045): Access denied for user 'pma'@'localhost' (using password: YES)
    Connection for controluser as defined in your configuration failed.
    mysqli_real_connect(): (HY000/1045): Access denied for user 'pma'@'localhost' (using password: YES)
    Connection for controluser as defined in your configuration failed.
    The import function works (to my surprise) and that's the thing I most of the time use.

    Can you guys be so kind and point me to where did I misconfigure the server?


    I followed the instructions to the letter but I skipped installing the following:
    * 12 Install Mailman (I'm not using it)
    * 14 Install BIND DNS Server (I'm using 3rd party DNS)
    ---
    Thank you all very much in advance.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    That combination of username, host, and password is not allowed to connect to the server. Verify the permission tables (reloading grants if required) on the server and that you're connecting to the correct server.
    Check with the Perfect Server Guide how you configured mariadb/mysql.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The password of the pma user that you created in these steps:

    Code:
    MariaDB [(none)]> CREATE USER 'pma'@'localhost' IDENTIFIED BY 'mypassword';
    MariaDB [(none)]> GRANT ALL PRIVILEGES ON phpmyadmin.* TO 'pma'@'localhost' IDENTIFIED BY 'mypassword' WITH GRANT OPTION;
    MariaDB [(none)]> FLUSH PRIVILEGES;
    MariaDB [(none)]> EXIT;
    does not match the password that you've set in the file:

    /usr/share/phpmyadmin/config.inc.php
     

Share This Page