debian 10 ispconfig 3 ssl issues and slow emails

Discussion in 'Installation/Configuration' started by ariban99, Apr 12, 2021.

  1. ariban99

    ariban99 Member

    Hi
    I just installed a brand new server using https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/
    the emails come into the server i can see them in mailq, then they disappear from mailq and take about 20 minutes to come into microsoft outlook, any advise?
    also during setup, it asked me if i want to apply the SSL to postfix, ftp etc... i said yes and it gave a dns error, it asked me if i want to ignore checking the dns and i said no, and it create its own internal ssl.
    now the dns is pointing fine, how do i update the ssl for postfix, ftp etc...?
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Your mail log shows what happened on your server, but it sounds like it was delivered to microsoft rather quickly; if that's the case, you would have to ask microsoft why it takes 20 minutes for them to deliver your message.

    Run ispconfig_update.sh --force to rerun the installer to request a certificate.
     
  3. ariban99

    ariban99 Member

    thank you
     
  4. ariban99

    ariban99 Member

    actually trying to upgrade i get this error
    Please choose the update method. For production systems select 'stable'.
    WARNING: The update from GIT is only for development systems and may break your current setup. Do not use the GIT version on servers that host any live websites!
    Note: On Multiserver systems, enable maintenance mode and update your master server first. Then update all slave servers, and disable maintenance mode when all servers are updated.

    Select update method (stable,nightly,git-develop) [stable]:

    There are no updates available for ISPConfig 3.2.4
    If you are sure you want to update to stable anyway, please use --force parameter
    DOWNGRADING MAY CAUSE ISSUES!
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Like @Jesse Norell wrote in #2, use command
    Code:
    ispconfig_update.sh --force
    Also, please post code and listing snippets in CODE tags.
     
  6. ariban99

    ariban99 Member

    now it worked. i must have spelled it wrong before.
    will this auto renew every 3 month?
     
  7. ariban99

    ariban99 Member

    just started working by itself, nice and fast
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    No. Why woud it need to auto-renew? ISPConfig panel notifies you when new version of ISPConfig is released, then you can do the upgrade. It is not regular 3 month interval between upgrades.
     
  9. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Yes, the cert will renew automatically.
     
  10. ariban99

    ariban99 Member

    i meant the cert, Th0m already wrote it will. thank you
    i did the cert but i still get errors that the cert is not validated and do i want to use this vert when connecting to postfix. is that normal?
     
  11. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Can you share the error messages?
     
  12. ariban99

    ariban99 Member

    yes, please see attached screenshot
     

    Attached Files:

  13. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    To which hostname are you connecting? The cert is valid for webserver1.bhherbalsolutions.com.
     
  14. ariban99

    ariban99 Member

    for some reason it started working today, yes webserver1..... was the hostname
     

Share This Page