Dbus error with Beryl on Ubuntu

Discussion in 'HOWTO-Related Questions' started by headphase, Oct 7, 2007.

  1. headphase

    headphase New Member

    I am having trouble initializing Beryl on Feisty Ubuntu:
    Code:
    **************************************************************
    * Beryl system compatiblity check                            *
    **************************************************************
    
    Detected xserver                                : AIGLX
    
    Checking Display :0.0 ...
    
    Checking for XComposite extension               : passed (v0.3)
    Checking for XDamage extension                  : passed
    Checking for RandR extension                    : passed
    Checking for XSync extension                    : passed
    
    Checking Screen 0 ...
    
    Checking for GLX_SGIX_fbconfig                  : passed
    Checking for GLX_EXT_texture_from_pixmap        : passed
    Checking for non power of two texture support   : passed
    Checking maximum texture size                   : passed (2048x2048)
    
    Reloading options
    beryl: dbus_bus_get error: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    beryl: Plugin 'dbus':initDisplay failed
    beryl: Couldn't activate plugin 'dbus'
    Couldn't initialise dbus. This should not happen!
    X connection to :0.0 broken (explicit kill or server shutdown).
    
    Xorg:
    Code:
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf(5) manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    	FontPath	"/usr/share/fonts/X11/misc"
    	FontPath	"/usr/share/fonts/X11/cyrillic"
    	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath	"/usr/share/fonts/X11/Type1"
    	FontPath	"/usr/share/fonts/X11/100dpi"
    	FontPath	"/usr/share/fonts/X11/75dpi"
    	# path to defoma fonts
    	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load	"bitmap"
    	Load	"ddc"
    	Load	"dri"
    	Load	"extmod"
    	Load	"freetype"
    	Load	"glx"
    	Load	"int10"
    	Load	"vbe"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    	Option		"ZAxisMapping"		"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"stylus"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"eraser"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"		"cursor"
    	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"ATI RADEON 7000"
    	Driver		"ati"
    	BusID		"PCI:1:0:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"ACER AL1917W"
    	Option		"DPMS"
    	HorizSync	28-72
    	VertRefresh	43-60
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI RADEON 7000"
    	Monitor		"ACER AL1917W"
    	DefaultDepth	16
    	SubSection "Display"
    		Depth		1
    		Modes		"1440x900" "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1440x900" "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1440x900" "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1440x900" "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1440x900" "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1440x900" "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    	InputDevice     "stylus"	"SendCoreEvents"
    	InputDevice     "cursor"	"SendCoreEvents"
    	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    
    Section "DRI"
    	Mode	0666
    EndSection
    I am using an ATI Radeon 7000
    and if I modify the Xorg to the HowTo, the graphics don't initialize
     
    Last edited: Oct 7, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

  3. headphase

    headphase New Member

    and if I modify the Xorg to the HowTo, the graphics don't initialize
     

Share This Page