dbus daemon not working with KDE3.5 and dbus-1.0.2

Discussion in 'Desktop Operation' started by Nanko, Mar 29, 2007.

  1. Nanko

    Nanko New Member


    I followed the HOWTO:
    http://www.howtoforge.com/dbus_kde_integration or
    (same author) in order to activate the sessionwide part of the dbus-daemon. Great article!

    However, using $HOME/.dbus-session relies on the output of dbus-launch. I have installed version 1.0.2, which returns:
    which is similar to that stated in the document under the second link above.

    The problem is that the statement:
    is missing in the output of dbus-launch!!

    Hence, when the file $HOME/.dbus-session is sourced, this variable is not published to the other applications and they will fail to identify the DBUS-daemon. Also, the scripts inserted in /etc/session.d/kdm/scripts/... will fail, since $DBUS_SESSION_BUS_PID is empty!

    I wonder wether this is a bug of dbus-launch or whether I have to insert the export command manually.

  2. stefbon

    stefbon New Member

    dbus error: no export for pid var???


    first thanks for your feedback!

    Second in my version (0.62) there is also no export for the variable
    DBUS_SESSION_BUS_PID. But the scripts I've written can handle that.

    When sourcing the ~/.dbus-session file, the variable is set. No explicit export command is necessary. When you open a new bashsession, and source the file in your homedirectory you'll see this.

    Why the scripts run into trouble I do not know.


Share This Page