Databases backup & restore

Discussion in 'Installation/Configuration' started by dynamind, Jan 26, 2012.

  1. dynamind

    dynamind Member

    Hello,

    I wanna move to a new x64 installation.

    The server is prepared with ISPconfig3.

    Now I dumped all databases on the old webserver and restored all databases on the new x64 webserver succesfully.
    In the database panel none of the restored mysql-databases shows up. Is there a way to re-index all available databases into ISPConfig?

    regards, dynamind
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No. But you can move the ispconfig database from the old system which contains the details for all databases to the new sysstem as well.
     
  3. dynamind

    dynamind Member

    mysql transfer

    excluding

    root, debian-sys-maint, and ispconfig from mysql/user and
    ispconfig from mysql/db

    right? Does the innodbs get transferred this way also?

    I had a curious problem (#1054) cause on my x86 server was mysql-server-5.5 ... on the x64 machine was the mysql-server-5.1 so I could not transfer the users. Now I upgraded to MySQL 5.5 and now the users got imported.

    thanks a lot.

    regards, dynamind
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am talking about the ispconfig database "dbispconfig", not the mysql.mysql database.
    Everything that you see in the ispconfig interface is in the ispconfig database.

    Thats right, but not related to the problem that databases were not displayed in ispconfig.
     
  5. dynamind

    dynamind Member

    mysql transfer

    ok, Till, should I exclude anything or transfer the whole dbispconfig?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Exclude the server and server_ip and sys_datalog tables if the server setup on the new server is not identical to the old system (linux distribution and version and ip addresses). If its the same, then you can copy the whole database. And make a backup of the current database, in case something goes wrong.
     
  7. dynamind

    dynamind Member

    error starting apache2

    [Thu Jan 26 18:34:35 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/ispconfig.conf at line 51 will probably never match because it overlaps an earlier Alias.
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:80 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:443 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:80 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:443 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost *:2340 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/ispconfig.conf at line 51 will probably never match because it overlaps an earlier Alias.
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:80 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:443 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:80 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:443 has no VirtualHosts
    [Thu Jan 26 18:34:35 2012] [warn] NameVirtualHost *:2340 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:2340
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
    ...fail!
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -O clf:/var/log/pure-ftpd/transfer.log -8 UTF-8 -u 1000 -E -Y 1 -A -b -D -H -B

    I did not overwrite apps.vhost, default, default-ssl, ispconfig.conf, ispconfig.vhost, only placed the additional domains/sites into /etc/apache27sites-available, and then enabled all sites with a2ensite > *

    at the console it shows:


    * Starting web server apache2 [Thu Jan 26 18:40:07 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/ispconfig.conf at line 51 will probably never match because it overlaps an earlier Alias.
    [Thu Jan 26 18:40:07 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:80 has no VirtualHosts
    [Thu Jan 26 18:40:07 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:443 has no VirtualHosts
    [Thu Jan 26 18:40:07 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:80 has no VirtualHosts
    [Thu Jan 26 18:40:07 2012] [warn] NameVirtualHost xx.xx.xxx.xxx:443 has no VirtualHosts
    [Thu Jan 26 18:40:07 2012] [warn] NameVirtualHost *:2340 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:2340
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.

    anyway it looks like I killed the logger. I'll reinstall.
     
    Last edited: Jan 26, 2012
  8. dynamind

    dynamind Member

    done

    I did it, finally moved my debian x86 server succesfully
    to a fresh debian x64 system.

    All done with your help.

    thanks a lot!

    regards, juergen
     

Share This Page