Database remote access to all doesn't work

Discussion in 'Installation/Configuration' started by SupuS, Feb 27, 2012.

  1. SupuS

    SupuS Member HowtoForge Supporter

    Hello,

    I checked database remote access option and leave emtpy IP's input field according to ispconfig manual:

    To allow connections from all remote hosts, leave this field empty.

    In phpMyAdmin privilegs tab nothing changed. I expected "%" value in host setting but "localhost" value remain. If I set specific IP host value is correctly set to this IP.

    How can I set "%" through ISPConfig?

    ISPConfig version: 3.0.4.3
    OS: Ubuntu 10.04

    SupuS
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Enable the remote access option in the mysql database settings.

    Either you did not wait until ispconfig has written the changes to the mysql priviliges table (see jobqueue in monitor tab) or the mysql root password has been changed so that the password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is wrong.
     
  3. SupuS

    SupuS Member HowtoForge Supporter

    Thank you for replay but I probably not explain problem clearly. I have set what you wrote:

    Code:
    # netstat -tap |grep mysql
    tcp        0      0 *:mysql                 *:*                     LISTEN      1197/mysqld
    
    and yes I wait for more than one minute and checked jobqueue in monitor tab and my mysql root password is correct.

    What I am reporting here is that remote access setting for all not work. Remote access works for specific IP only. May be a bug?

    SupuS
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It works fine here, just tested it in 3.0.4.3 On Debian 6. So if its a bug, then its not reproducable on Debian servers.

    When I add a database with renote access enabled and a empty remote access IP field, ispconfig inserts a user and db record pair for localhost and a second user and db record pair for %.
     
  5. SupuS

    SupuS Member HowtoForge Supporter

    I tested it on two Ubuntu 10.04 boxes and I found that remote access settings not work at all (IP for remote access on first server probably was added in previous ISPConfig version .. I don't know). When I check remote access nothing change in phpMyAdmin privilegs tab. When I check remote access and fill specific IP I see no changes again.

    Messages in debug mode is not helpfull:

    Code:
    2012-27-02 15:14  www.example.com  Debug  Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    2012-27-02 15:14  www.example.com  Debug  Processed datalog_id 143
    2012-27-02 15:14  www.example.com  Debug  Changing MySQL remote access privileges for database: cXXXXXXX
    2012-27-02 15:14  www.example.com  Debug  Calling function 'db_update' from plugin 'mysql_clientdb_plugin' raised by event 'database_update'.
    2012-27-02 15:14  www.example.com  Debug  Found 1 changes, starting update process.
    2012-27-02 15:14  www.example.com  Debug  Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    Is there some more detailed log file? How I can find why it doesn't work?

    SupuS
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you have most likely a problem with the mysql root password (the password in this file has to be the root password, not the ispconfig password and the name of the user must be "root"). Check the password in the mysql_clientdb.conf again by using this passwod to log into the database with the "mysql" commandline tool on "localhost".
     
  7. SupuS

    SupuS Member HowtoForge Supporter

    As I said before .. settings in /usr/local/ispconfig/server/lib/mysql_clientdb.conf are correct. I tested it now by:

    Code:
    mysql -u root -p mysql
    and it works fine.

    SupuS
     
  8. SupuS

    SupuS Member HowtoForge Supporter

    Please can somebody test adding permissions by ISPConfig on ubuntu 10.04 box? It still doesn't work on my servers :(
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    It works fine here on my servers with ISPConfig 3.0.4.3. Did you add the databases in ispconfig or with the remote api?
     
  10. SupuS

    SupuS Member HowtoForge Supporter

    I added database directly in ispconfig. Here is my procedure (directly in ISPConfig):

    1) create database and safe database without remote access
    2) edit database and allow remote access only
    3) check database permission in phpMyAdmin => permission is for localhost only => remote access doesn't work
    4) add permission manually in phpMyAdmin => remote access work as expected

    In point 2 I can allow specific IP only and result is the same .. no changes in permissions at all.

    SupuS
     
  11. SupuS

    SupuS Member HowtoForge Supporter

    Solved in next version.
     
  12. celocore

    celocore New Member HowtoForge Supporter

    I had the same problem after updating ISPC from 3.0.3.3 to 3.0.4.6. The Reason that ISPC could not update the user table in mysql database was the change of password use. It seems, that ISPC since Version 3.0.4.x works with password hashes instead of clear text passwords.
    After setting the passwor again, the update for remote access works fine.
     

Share This Page