Database issues on multiserver setup

Discussion in 'Installation/Configuration' started by jamesl22, Oct 27, 2011.

  1. jamesl22

    jamesl22 New Member


    I have followed the multiserver setup tutorial for debain 6. All is working well except when I create a database it gets created on the webserver's mysql server rather than the dedicated mysql server. How do I fix this?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you selected the database server and not the webserver server in the mysql database details when you create a new database.
    Samo_slo likes this.
  3. jamesl22

    jamesl22 New Member

    I can select the mysql server as admin but there is not option to do so as a regular user? Even selecting it as admin creates it on the webserver.
    Last edited: Oct 27, 2011
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The server for regular users is set by the admin in the client limits of that user.
  5. jamesl22

    jamesl22 New Member

    DB server is already set to the actual database server. If I select allow remote access and input the ip of the webserver I can connect. Even though I commented out
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Changing the value does not affect any existing database, the value in the client setting is the default for new databases.

    1) Delete the Database.
    2) Go to client settimngs, make sure that the correct database server is selecetd there and click on save. You have to save the clinet settings once even if the correct server shows up already, as if there is only one db server, then this one shows up of course in the list even of you have not selected it yet.
    3) Create a new database as client.

    Thats required beside the above settings, even if it is not related to the original problem. To access a database from a specific IP, you have to allow access from this IP to the database if the database and web server are not the same server.
    Last edited: Oct 27, 2011
  7. jamesl22

    jamesl22 New Member

    Thats fixed it.

  8. Samo_slo

    Samo_slo Member

    THIS!!! Thanks Till... I'm having really bad time getting my multiserver setup to work, the HowTo was perfect, but the configuratio is hard when you don't have a clue. When I created the db for a website I've forgot to select on what server and it created on the mail.server and I was looking for it on my web server and cursing why can't things work.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Go to system > server services and ensure to deselect db server for all servers excapt of the database server. This ensures that only the database server shows up in the database server list so you cant accidently select a wrong server. Do the same for aother services. e.g. in case that the mail server has web server services selected there, then disable it to ensure that only the mail server shows up as possible target for email domains in the email module.
    Samo_slo likes this.

Share This Page