Database creation fail updating ISPConfig 3 to

Discussion in 'Installation/Configuration' started by kamalito, Jul 15, 2010.

  1. kamalito

    kamalito New Member


    I've updated ISPConfig 3 to on a fresh Debian 5 Lenny server with ISPConfig 3 on it.
    After that, I've created a new client, a new DNS, a new web site and a new database for that client. Everything seems fine but the newley created database doesn't appear on phpMyAdmin.

    I've made the same operations on another ISPConfig 3 server ( and the database is created within some seconds.

    I have no idea why the database is not created on the server. Any help is appreciated.
  2. damir

    damir New Member

    Is this single or multi server install?
  3. kamalito

    kamalito New Member

    single server installation
  4. damir

    damir New Member

    What does log files say?

    Are there any databases created in /var/lib/mysql ?
  5. kamalito

    kamalito New Member

    No database was created under /var/lib/mysql

    As for the log files, when ISPConfig is set in Debug mod, I have :
    Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    No Updated records found, starting only the core.
    Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    A linked problem : when I create a web site, it is not created under /var/www or /var/www/clients.

    It seems like ISPConfig doesn't update the system
  6. damir

    damir New Member

    How did you installed ispconfig3. Which guide have you followed?
  7. kamalito

    kamalito New Member

  8. damir

    damir New Member

    Can you try to manually create database. Login to mysql console mysql -u root -p and try to create database by issuing following command, create database demodb;

    If that goes than something went wrong with installations.

    Have you created any Sites? Does vhost files gets created in /etc/apache2/sites-enabled
  9. kamalito

    kamalito New Member

    The manual creation of a database works.
    When I create a new web site with ISPConfig, vhosts files are not created in /etc/apache2/sites-enabled

Share This Page