Database backup ISPConfig 3.0.5 RC2

Discussion in 'Installation/Configuration' started by Gijs, Feb 22, 2013.

  1. Gijs

    Gijs New Member

    Hi,

    I installed ISPConfig 3.0.5 RC2 and it says that the backup should include the database which is beautifull but if I choose "download" in the backup section, the backup included in the /backup doesn't contain the database file which is less beautifull I think.

    Am I doing something wrong or is the database only included in the restore process?

    Thanks for the answer.
     
  2. pawan

    pawan New Member

    You should assign database to your website to have the database backup, if yours is a old installation, you have to do it manually for every website.

    For newer website the ispconfig will automatically ask you to assign the database.
     
  3. Gijs

    Gijs New Member

    Thats it! Thanks for the help
     
  4. Gijs

    Gijs New Member

    Hi Pawan,

    I thought that was the solution but it isn't. The database is still not backuped. If I download the backup file it contains only the FTP data. The database is not included in there.

    Do you have any other suggestions?

    Thanks again
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Backups are created nightly. Have you waited until the next day before you tried the download again?
     
  6. Gijs

    Gijs New Member

    Well, their are also backups made this night and they don't include the databases either. And it is a fresh website created on the 3.0.5 final.

    Their don't have to be any specific settings right? Just create a database user, the database and the website isn't it?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. Please check that the applications sudo and mysqldump are installed on your server and that the mysql root password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is correct and does not contain any special chars.
     
  8. Gijs

    Gijs New Member

    Aha, mysql_clientdb.conf says that the mysql database is localhost, but it is not, so that should be the solution.
    I will have to wait for the next backup tonight but thanks so far again!
     
  9. Gijs

    Gijs New Member

    It's working now!
    External MySQL backup still didn't work but I didn't see any good reason to use an external database so I am using the local MySQL database now and that works with the backup.
     
  10. arraken

    arraken Member HowtoForge Supporter

    Hi,

    In my multiserver setup, the db backup also doesn't work. The webserver is on a different server than the db server. I have updated my mysql_clientdb.conf file accordingly:

    Code:
    <?php
    
    $clientdb_host                  = 'db1.domain.tld';
    $clientdb_user                  = 'root';
    $clientdb_password              = 'rootpassword for mysql on db1';
    
    ?>
    
    Mysqldump and sudo is installed on both servers.

    However, if I do:
    Code:
    mysqldump -h db1.domain.tld -u root -p c1testdb1 > c1testdb.dump
    I get:
    Code:
     Access denied for user 'root'@'web1.domai.tld' (using password: YES) when trying to connect
    Does that indicate the problem?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, this indicates the problem, the mysql root password is not correct or you dont have a root user record on the db server that is allowed to login from your web server.
     
  12. arraken

    arraken Member HowtoForge Supporter

    Ok, fixed that now - I didn't have a root user record on the db-server. The command "mysqldump -h db1.domain.tld -u root -p c1testdb1 > c1testdb.dump" works correctly now when I execute it on my ISPConfig master server.

    However, the DB-Backup still doesn't work. The ISP-Config interface shows the backup, with the "restore" and "download" options, but there's no db-backup in the /var/backup/.. folder, and neither "restore, nor "download" does anything.

    The password in my mysql_clientdb.conf file definitely is correct. What else could be the problem?
     

Share This Page