Darwin Streaming server ipnum change

Discussion in 'HOWTO-Related Questions' started by zimbot, Feb 19, 2009.

Thread Status:
Not open for further replies.
  1. zimbot

    zimbot New Member

    friends,
    i have successfully installed a QT streaming server by the wisdom of
    http://www.howtoforge.com/apples-darwin-streaming-server-on-centos-5.2

    But I have an issuee .
    when I installed i gave the server the ipnum of 192.168.NNN.81
    I have since needed to change this server to a diffrent ip number
    all that is OK except for the QT server. The new machine num is
    192.168.NNN.92
    I can log in via : 192.168.NNN.90:1220 but - of course the server snapshot says the number is the number it was installed under (81)
    this number is seen also on the upper right

    and what used to work as rtsp://192.168.nnn.81 nolonger works at rtsp://192.168.nnn.81.

    so is there a way that i can "tell" the server that it is this new number.

    I have read that one can change a file
    etc/streaming/streamingadminserver.conf
    and there are 2 lines to bind to an ipNum

    but i do not have a file named that there?

    so - how can i correct thsi so that the server knows it is the new number?

    thanks
     
  2. falko

    falko Super Moderator

    What's the output of
    Code:
    updatedb
    locate streamingadminserver.conf
    ?
     
  3. zimbot

    zimbot New Member

    1st -- thanks for the reply

    i tried your suggestion
    in 2 lines

    [root@Vgrid ~]# updatedb
    [root@Vgrid ~]# locate streamingadminserver.conf
    /etc/dss/streamingadminserver.conf
    /usr/src/redhat/BUILD/DarwinStreamingSrvr6.0.3-Source/WebAdmin/streamingadminserver.conf
    [root@Vgrid ~]#

    funny I thought i tried a find from / ( root )
    for streamingadminserver.conf

    but did not find anything

    so i suppose we now know where streamingadminserver.conf is
    and that location is in 2 places --?
    1>>
    /etc/dss/streamingadminserver.conf

    2>>
    /usr/src/redhat/BUILD/DarwinStreamingSrvr6.0.3-Source/WebAdmin/streamingadminserver.conf

    I opened /etc/dss/streamingadminserver.conf
    and all it has inside is
    ssl=0

    so -- do i need to add something to --both?
    or just the 1 in
    /etc/dss/
    and will that then change the RTSP IpNum?
    and will it also change the IpNum I see on the admin page?


    -----------------( and this might be nothing but...
    so -- i have not changed this yet -- is that advised or a bad idea?

    i find in /var/dss/config a xml file names streamingserver.xml

    i was wondering about making the following cahnge to it
    it was
    <PREF NAME="bind_ip_addr">0</PREF>
    i might change it to
    <PREF NAME="bind_ip_addr" >192.168.nnn.NewNum</PREF>

    <!-- This tells the server what IP address it should accept -->
    <!-- client connections on. A value of 0 means all IP addresses currently -->
    <!-- enabled for the machine. -->
    <!-- <PREF NAME="bind_ip_addr">0</PREF> -->
    <PREF NAME="bind_ip_addr" >192.168.nnn.NewNum</PREF>


    with NewNum being a real number

    I am also wondering does the change to /etc/dss/streamingadminserver.conf
    then change this xml file?

    Thanks again!
     
  4. falko

    falko Super Moderator

    I think I'd try to change the IP in the XML file in /var/dss/config.
     
  5. zimbot

    zimbot New Member

    it works

    i edited the etc/dss/streamingserver.xml

    changing the
    <PREF NAME="bind_ip_addr">0</PREF>
    i might change it to
    <PREF NAME="bind_ip_addr" >192.168.nnn.NewNum</PREF>

    and it worked with 192.168.nnn.NewNum -- and the snapshot showed that num and all was good -- except
    I could not stream past my FireWall ( cisco pix515e )
    i had oked holes
    tcp 554
    tcp 7070
    udp 6970 - 9999
    even
    tcp 8080
    tcp 8000

    i could ping the num 208.nnn.nnn.NewNum
    I have the alias and nat all correct...
    still -- no joy

    then I enabled port 80 ( via the admin webpage )
    and -- now it works

    i intend to close the ports
    tcp 8080
    tcp 8000
    i do not think those are doing anything...
    so the fix
    was the etc/dss/streamingserver.xml
    and port 80

    Thanks
     
  6. zimbot

    zimbot New Member

    so happy happy

    i suppose this is closed...
    points award:Ded to Falko ( if it works that way )
     
: centos5, dss
Thread Status:
Not open for further replies.

Share This Page