D_BOUNCE does not care about dsn_cutoff_level

Discussion in 'Installation/Configuration' started by Aron, Dec 8, 2015.

  1. Aron

    Aron New Member

    I tried to send myself spam, and did not get any notice back to the sender email address that I had sent spam, so I changed the 50-user file so that final spam destination was changed to D_BOUNCE. This is giving me a notice back to all spam messages, including the messages that should not receive one due to the dsn_cutoff level. In other words, i set cutoff level to 20, so I should only get notice on all spam with a score below 20, but i get a notice back on all spam messages.

    If I change the final spam destination to discard in the /etc/amavis/conf.d/50-user file it does not send any notice at all, so it seems like i have to set this manualy to get a notice, and that there is not way in ispconfig to control this ?

    What I want is for all spam with a level below 5 to trigger a dsn notice bag to the sender address, that the email was not accepted and was deleted, and all spam above 5 to just be discarded without any notice.
    Any ideas ?
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You should not bounce spam. This can lead to a backscatter-problem. Better mark the mail as spam or move spam-mails to a special-folder like Junk. You can set all levels in ispconfig.
    BTW: accept and delete is never a good idea.
  3. Aron

    Aron New Member

    I have a gmail account, and I just want to handle spam the same way gmail is handeling it, in other words, when you send an email to gmail that is possible spam, gmail server refuse to accept the email, and is sending you a message that they did not deliver the mail to the person you tried to send it to. Why is it gmail is doing this - if it is such a bad idea ?? That is not really a question I want an answer to, I just want to know if anybody knows how to do what I am trying to do:

    If my server receive a message that is possible spam with a low score, I want to discard the message, and send a message back to the sender that the email was refused by the server becuase it is possible spam. Exactly the same way GMAIL is handelings such messages.
    I am using ispconfig3, and this feature is not longer working on my server after i started using ispconfig3, because I am so far not able to configure this with ispconfig3. I was however able to do this fine, before i started to use ispconfig 3. So I am thinking this is me not understanding ispconfig 3 properly.
    Last edited: Dec 8, 2015
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    I woul not accept the mail. If you accept a mail you can not delete this mail. It´s a better idea to reject the mail before postfix accepts it. You can do this with postfix content_proxy instead of content_filter.
  5. Aron

    Aron New Member

    Thank you for your reply florian030,

    I have installed The perfect Server - Ubuntu 15.10, apache, php etc. from the tutorial here on howtoforge.com - and want to do the same as gmail is doing - sending a message back after rejecting a spam message, telling the sender that their message was rejected.

    So my question is:
    How do I send a reply to the sender - that the spam email was rejected. But only to the messages that have a very low spam score. ?? Messages with a spam score above 5 is rejected with no message sent back that it was rejected.
    Last edited: Dec 8, 2015
  6. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    content_proxy REJECTS spam-mails. It´s up to the other MTA to send the mail back to the sender. If you reply/bounce each spam-mail, your server might be blacklisted in a very short time. Did you know, that most spammers use foreigen email-adresses? ;)
  7. Aron

    Aron New Member

    This is what I do:
    from my gmail account i send a message that has spam in it (scores 9) to my other account on own my mail server. My server is rejecting the email, but my gmail account does not get anything back at all, so there is no way for the gmail account holder to know that the message was not delivered.

    This is happening with the standard setup, just like it is all explained in the tutorial i have followed mentioned in a previous message.
    I use the normal spam policy, and have not changed anything at all in the config files or anywhere else. I have kill level at 5.

    I have tried a few things to correct the problem:
    On thing i have tried is (on a second server running the same) to play around with the D_BOUNCE and other settings to figure out how ispconfig is effecting the rejection etc. amavis ans so on, but I have had no luck getting this to work.
    On my previous server, running all manually configured stuff that my staff set up a few years ago, this was never a problem, but i do not have any idea what he did, and he was fired because he we unreliable, so i can not get his help to figure out how to do this.
    Last edited: Dec 8, 2015
  8. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    See #4 - just use amavis as a proxy-filter (before queue content filter) and set $final_spam_destiny = D_REJECT; in 50-user. This will reject spam-mails instead of accepting them.

Share This Page