Customer subdomain put on wrong site?

Discussion in 'Installation/Configuration' started by Norman, Mar 26, 2012.

  1. Norman

    Norman Member HowtoForge Supporter

    I have a customer who has created site

    subdomain.domain.ext
    it also has the following co-domains:
    www.subdomain.domain.ext
    and subdomain.domain.ext

    Since upgrading to the latest ispconfig 2 version we've seen some sporadic weird behaviour.
    One was /etc/passwd being nulled and now this new problem.

    It seems that subdomain.domain.ext was also put on entirely different sites co-domain list belonging to a totally different customer under another reseller.

    What may be the cause of this?

    the subdomain can't be edited as admin, it simply says I dont have permission to access this object.

    co-domain subdomain.domain.ext on the site 1 and site 2 has different docids.

    What would be a quick fix?
    and what would be a permanent fix to make sure this wont happen in the future?

    Is there any known issues such as this with doublette co-domains?
     
  2. Norman

    Norman Member HowtoForge Supporter

    Update: When I removed the co-domain subdomain.domain.ext for customer1 site1 the co-domain also disappeared on site2. But the "paperbin" of customer1 was empty, but the paperbin of customer2 had the co-domains there.

    Tried creating a new site with customer1.
    All codomains/subdomains created on said site gets put on customers2's site codomains.

    Can't access or remove them from customer2s site.
    Tried changing owner of site between different owners, didnt help.

    If I delete codomain on site1 it gets removed on customer2s site but put in customer2s trash.

    This is really odd and would be thankful to sort this out.
     
    Last edited: Mar 26, 2012
  3. Norman

    Norman Member HowtoForge Supporter

    Any ideas?
    Or a solution?

    Trying to add a co-domain on any other site gives "domain is owned by another user" error message. Although the site itself is the domain and co-domain just a subdomain.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There is a corrupted link in the database, to fix that delete the co-domain so that its in the trahs folder and then empty the trash and then create the co-domain again.
     
  5. Norman

    Norman Member HowtoForge Supporter

    Tried doing that.
    Any new site I made had all co-domains put on that one site... so what I did was to delete the site that seemed to have gained superpowers (own all co-domains).

    When I did that a new entry showed up in DNS view of ISPconfig2.
    I clicked the site but it showed up as a normal site config docid which was odd. Deleted that one as well.

    That seems to have fixed it.
     

Share This Page