Customer A sends Customer B Mails, tagged as spam (same machine)

Discussion in 'Installation/Configuration' started by Ben, Jul 3, 2007.

  1. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Hi folks,

    did not knew how to get a better topic for my problem. My server, managed with ISPConfigs sometimes tags mails as spam when customer A sends an email to customer B while both are homed on the same machine.
    The SA Infos about why it tagged are the follwing:
    Regarding the sender IP, sure its the clients dialup IP from the machine it sended the E-Mail via Outlook...
     
  2. falko

    falko Super Moderator ISPConfig Developer

    So that's not your server's IP address? Does your server have a static IP address?

    I've had the same problem about three weeks ago when I send someone a mail, but it bounced because my IP address (not the one of my mail server) was blacklisted. But I'm not sure why this happened... :(
     
  3. minskog

    minskog New Member

    this happen to me and i can't find solution :mad:

    The problem is spamassasin, because if you put these black lists in postfix main.cf take de servers ip, but spamassasin takes client ip, i dont know why ....
     
  4. Ben

    Ben ISPConfig Developer ISPConfig Developer

    No the IP is I guess the client ones. But not the one of my server. The server itself has a static IP.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Yes, seems to be a SpamAssassin problem: http://lists.roaringpenguin.com/pipermail/mimedefang/2003-October/017476.html
    (I think it's really stupid to block client IP addresses... :()

    According to http://spamassassin.taint.org/doc/Mail_SpamAssassin_Conf.html , you could put
    Code:
    skip_rbl_checks 1
    into your SpamAssassin configuration to fix this problem.
     
  6. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Yes, SA also checks RBLs in case of authenticated users and not only the "anonymmously" delivered emails.
    I discussed this also with some others and there was the idea of "submission", that means to have one port, where only authenticated users may deliver emails but these are then not checked for spam.
    I will try this and update here if and how it works.

    EDIT: Well in an ISPConfig Szenario it won't work, cause SA gets called via procmail. So procmail has to determine if the mail that's shipped through SA comes from an authenticated user or not. Does anybody got an idea here?
     
    Last edited: Jul 5, 2007
  7. falko

    falko Super Moderator ISPConfig Developer

    You added
    Code:
    skip_rbl_checks 1
    to SpamAssassin's configuration, and emails were still flagged as spam?
     
  8. Ben

    Ben ISPConfig Developer ISPConfig Developer

    @falko: But this implies that spamassasin does do not an RBL Check generally.
    Sure it solves the problem + more.

    To wipe out the more it would be ok if it would be possible to change the user's procmail.rc to only run SA in case of the mail came from an mailaccount not homed on the same system.
     
  9. minskog

    minskog New Member

    Yes, but i format this server, install fresh ispconfig and now spamassasin works ok. With the same server ip and sending from same clients :confused: Could be any procmail configuration directive?
     
  10. Ben

    Ben ISPConfig Developer ISPConfig Developer

    @Falko: Temporaryly (till I find a better solution), I added the line to
    "/home/admispconfig/ispconfig/tools/spamassassin/etc/mail/spamassassin/local.cf"
    was this the right config file for SA? And if so, how do I prevent this file to be overwritten
    after upgrading ISPConfig?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's the correct file.

    Well, you'd have to modify the new local.cf file each time you upgrade ISPConfig. :(
     
  12. minskog

    minskog New Member

    This is happening here in other server. This server is untouched from weeks and it starts to fail last friday suddenly... I think that the best solution is Ben idea, not check local accounts for rbl.

    Edit: i disabled rbl checks, and continues marking emails.
     
    Last edited: Aug 20, 2007
  13. jmroth

    jmroth ISPConfig Developer ISPConfig Developer

    Yes, this can sometimes be not easy.
    What I do is use SpamAssassin's POPAuth module.
    Not sure if it comes with ISPConfig, but you can get it from Spamassassin's homepage and put it here:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.8.8/Mail/SpamAssassin/Plugin/POPAuth.pm
    Then you have to run a daemon like pop-before-smtp (debian) that checks logs for people that have recently checked their mail successfully, and mail sent by those people will end up in the ALL_TRUSTED group in the spamchecks.
     

Share This Page