Custom PHP settings not taking effect with PHP-FPM

Discussion in 'Installation/Configuration' started by darkangel, Mar 19, 2013.

  1. darkangel

    darkangel New Member

    Hi,

    I just switched a site to PHP-FPM, and it seems like the Custom php.ini settings are not taking effect. I see them in /etc/php5/fpm/pool.d/web2.conf:

    php_admin_value[open_basedir] = none
    php_admin_value[session.save_path] = /var/www/clients/client1/web2/tmp
    php_admin_value[upload_tmp_dir] = /var/www/clients/client1/web2/tmp

    php_admin_value[realpath_cache_size] = 1M
    php_admin_value[error_reporting] = E_ALL & ~E_NOTICE & ~E_DEPRECATED
    php_admin_flag[magic_quotes_gpc] = On
    php_admin_value[session.save_path] = "0;0660;/var/www/clients/client1/web2/tmp"
    php_admin_value[session.cookie_domain] = ".***.net"
    php_admin_value[post_max_size] = 55M
    php_admin_value[upload_max_filesize] = 50M

    ... but if I var_dump(get_magic_quotes_gpc()); I get int(0), and the settings aren't visible using phpinfo() either.

    ISPConfig Version: 3.0.5.1
    Debian GNU/Linux 6.0.7 (squeeze)

    Please help.

    Edit: phpinfo() shows "Server API: CGI/FastCGI", should this be "FPM/FastCGI"? If so, any idea as to why it's not working?
     
    Last edited: Mar 19, 2013
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes. Please check your setup and your settings for the website in ISPConfig.
     
  3. darkangel

    darkangel New Member

    Our host hadn't installed mod_fastcgi, I think that was the issue.
     

Share This Page