Custom php.ini with "Sury" Packages

Discussion in 'General' started by Hbod, Jul 25, 2018.

  1. Hbod

    Hbod Member

    Hi,

    I followed one of the tutorials installing PHP 5.6 - 7.2 using the sury deb packages. Everything is working fine, except the custom php.ini settings inside a site. I can't even activate "display_error".

    Did I miss something? Do I have to include something special in order to get this work?

    Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which PHP mode do you use? a custom php.ini file is usef for the fastcgi mode and the cgi mode. The PHP-FPM mode supports custom settings as well, but these are stored inside the pool file and not a php.ini.
     
  3. Hbod

    Hbod Member

    FPM, sorry, I forgot to mention it. If I add additional ini settings, they won't be applied to websites using FPM.
     
  4. Hbod

    Hbod Member

    See my attachment. This won't do anything for example, while it was working in the past.
     

    Attached Files:

  5. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    Are you on ubuntu? I can confirm that it defntily does work for debian stretch.

    Is there any error happening? do you see a vhost.err file on apache, some debug entries of ispconfig anything that could lead to some sort of issue? Usually something "simple" like this doesn't just fail for no reason.

    Simple in terms of, it adds text to a template file...
     
    Last edited: Jul 25, 2018

Share This Page