Custom php.ini settings field format.

Discussion in 'Installation/Configuration' started by scottrill2, Apr 15, 2011.

  1. scottrill2

    scottrill2 Member

    I had a quick question about how the formatting (word wrap?) occurs in the "Custom PHP.ini Settings" Box/field.



    I have a bunch of php settings saved in a regular text doc. In the doc it appears like so:

    Code:
    # Protect mail forms against spammer attacks (Effectively disables any headers
    # injected from user input. Very important.
    suhosin.mail.protect=2
    


    It is all nice and neat with each line having either a comment character followed by text to remind me what the heck it does, or it has the command itself.

    Now when I paste the commands into the custom php.ini settings box in ISPConfig 3 it butchers it sorta. I don't whether it is because of word wrapping or what. But it looks like so:


    Code:
    # Protect mail forms against spammer attacks (Effectively 
    disables any headers
    # injected from user input. Very important.
    suhosin.mail.protect=2

    Do I need to do anything special when I paste into that box? Do I need to add another "#" infront of "disables" ? Will the way it is displayed return an error or perhaps not let the php setting be applied?


    Thanks as always folks,

    Scott
     
    Last edited: Apr 15, 2011
  2. falko

    falko Super Moderator

    I guess this happens because of automatic word wrapping. I don't think ISPConfig adds a line break, so I don't think you have to add another #.
     

Share This Page