Custom php error Call to undefined function gd_info()

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Oct 29, 2018.

  1. pawan

    pawan Member HowtoForge Supporter

    I have compiled php5.4.45 with these optons in Ubuntu 18.04
    Code:
    ./configure --prefix=/opt/php-5.4.45 --with-pdo-pgsql --with-zlib-dir --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --enable-exif --enable-bcmath --with-mhash --enable-zip --with-pcre-regex --with-pdo-mysql --with-mysqli --with-mysql-sock=/var/run/mysqld/mysqld.sock --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --with-openssl=/opt/openssl --with-fpm-user=www-data --with-fpm-group=www-data --with-libdir=/lib/x86_64-linux-gnu --enable-ftp --with-kerberos --with-gettext --with-xmlrpc --with-xsl --enable-opcache --enable-cgi
    Not installed php-fpm though.
    The compilation was completed successfully. but some sites I am getting the error like - mention in the subject as also -
    PHP:
    Call to undefined function imagecreatetruecolor()
    I have a copy of /opt/php5.4.45 compiled in Ubuntu 16.04.
    Can I make it work in Ubuntu 18.04
    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the gd lib is missing in the new php. You can try if the php from Ubuntu 16.04 works, but I guess it will not work.
     
  3. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Till is right, I assume you have missed adding --with-gd to the ./configure command.
     
    pawan likes this.
  4. pawan

    pawan Member HowtoForge Supporter

    Thanks that worked.
     

Share This Page