Custom mail policy not working...

Discussion in 'ISPConfig 3 Priority Support' started by rob_morin, Dec 4, 2018.

  1. rob_morin

    rob_morin Member HowtoForge Supporter

    Hello all... I created an email policy for a client, rather than use the default ones.
    In this new policy i have the following settings:

    Policy Tab:
    everything is no, except Policy name(New_Policy)

    Quarantine Tab:
    everything is [email protected]@domain.com

    Tag Level:
    -999
    4.50
    15
    0.0
    999.99
    Yes
    empty
    *** SPAM ***

    Other Tab:
    Everything as default

    When i tail the log and send a test email using the NORMAL policy i see what i should see:

    Dec 4 08:45:22 mail2 amavis[21117]: (21117-05) Blocked SPAM {DiscardedInbound,Quarantined}, [74.6.131.42]:33762 [74.6.131.42] <[email protected]_domain.com> -> <[email protected]_domain>, quarantine: [email protected]_mailbox.com Queue-ID: CDF86B000A2, Message-ID: <[email protected]_domain>, mail_id: WD4UTfoBiT6e, Hits: 999.901, size: 5966, dkim_sd=s2048:yahoo.ca, 1468 ms

    Now with the new policy i made(New_policy) I see this in the logs when i tail it:

    Dec 4 08:45:19 mail2 amavis[21262]: (21262-02) Blocked SPAM {DiscardedOpenRelay}, [74.6.131.42]:38597 [74.6.131.42] <[email protected]_domain> -> <[email protected]_with_new_policy.com>, Queue-ID: A4640B000A2, Message-ID:
    <[email protected]_domain.com>, mail_id: m_vyguuH4Xpv, Hits: 999.902, size: 5977, dkim_sd=s2048:sendin_domain, 1233 ms


    So what is wrong??? Setups are identical other than policy name.

    Thanks...
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Compare the policys in the database to see if there are any differences and ansure that you applied the policy to the mailbox and / or mail domain. If this does not help to find the reason, then you can use debug mode in amavis to get more details from amavis how and why which policy is applied to an email.
     
  3. rob_morin

    rob_morin Member HowtoForge Supporter

    They are both the same.... SO I tried this.... I took Trigger_happy policy that already existed and modified it to send spam to an email address. Then i went to the domain name in question and switched the policy from that custom one to trigger_happy and it worked as expected!

    I then switched back to the custom and it did NOT work... so its like any custom polices dont work with quarantine email address???
     
  4. rob_morin

    rob_morin Member HowtoForge Supporter

    Here is the custom policy:
    *************************** 8. row ***************************
    id: 8
    sys_userid: 1
    sys_groupid: 1
    sys_perm_user: riud
    sys_perm_group: riud
    sys_perm_other: r
    policy_name: koch
    virus_lover: N
    spam_lover: N
    banned_files_lover: N
    bad_header_lover: N
    bypass_virus_checks: N
    bypass_spam_checks: N
    bypass_banned_checks: N
    bypass_header_checks: N
    spam_modifies_subj: Y
    virus_quarantine_to: [email protected]
    spam_quarantine_to: [email protected]
    banned_quarantine_to: [email protected]
    bad_header_quarantine_to: [email protected]
    clean_quarantine_to:
    other_quarantine_to:
    spam_tag_level: -999.00
    spam_tag2_level: 4.50
    spam_kill_level: 15.00
    spam_dsn_cutoff_level: 0.00
    spam_quarantine_cutoff_level: 999.99
    addr_extension_virus:
    addr_extension_spam:
    addr_extension_banned:
    addr_extension_bad_header:
    warnvirusrecip: Y
    warnbannedrecip: N
    warnbadhrecip: N
    newvirus_admin:
    virus_admin:
    banned_admin:
    bad_header_admin:
    spam_admin:
    spam_subject_tag:
    spam_subject_tag2: *** SPAM ***
    message_size_limit: 0
    banned_rulenames:
    policyd_quota_in: -1
    policyd_quota_in_period: 24
    policyd_quota_out: -1
    policyd_quota_out_period: 24
    policyd_greylist: N


    Here is Trigger_happy after i modified it:

    *************************** 6. row ***************************
    id: 6
    sys_userid: 1
    sys_groupid: 0
    sys_perm_user: riud
    sys_perm_group: riud
    sys_perm_other: r
    policy_name: Trigger happy
    virus_lover: N
    spam_lover: N
    banned_files_lover: N
    bad_header_lover: N
    bypass_virus_checks: N
    bypass_spam_checks: N
    bypass_banned_checks: N
    bypass_header_checks: N
    spam_modifies_subj: Y
    virus_quarantine_to: [email protected]
    spam_quarantine_to: [email protected]
    banned_quarantine_to: [email protected]
    bad_header_quarantine_to: [email protected]
    clean_quarantine_to:
    other_quarantine_to:
    spam_tag_level: -999.99
    spam_tag2_level: 5.00
    spam_kill_level: 15.00
    spam_dsn_cutoff_level: 0.00
    spam_quarantine_cutoff_level: 999.99
    addr_extension_virus:
    addr_extension_spam:
    addr_extension_banned:
    addr_extension_bad_header:
    warnvirusrecip: N
    warnbannedrecip: N
    warnbadhrecip: N
    newvirus_admin:
    virus_admin:
    banned_admin:
    bad_header_admin:
    spam_admin:
    spam_subject_tag:
    spam_subject_tag2: *** SPAM ***
    message_size_limit: 0
    banned_rulenames:
    policyd_quota_in: -1
    policyd_quota_in_period: 24
    policyd_quota_out: -1
    policyd_quota_out_period: 24
    policyd_greylist: N
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Use amavis debug mode when you want to find out more. Amavis connects itself directly to the database and reads it's data from there, ispconfig is not involved in that. And your ISPConfig version is 3.1.13? As I wonder why you got that php warning which was solved in recent versions.
     
  6. rob_morin

    rob_morin Member HowtoForge Supporter

    ok i chnaged warnvirusrecip: Y to warnvirusrecip: n and it worked.....
    fantastic!
     
    till likes this.

Share This Page