Custom login issues

Discussion in 'Server Operation' started by arspoetica, Oct 16, 2012.

  1. arspoetica

    arspoetica New Member

    So I clicked the box for custom logins and changed the login name to '', but it changed my email address as well... It was [email protected] and now it is [email protected]

    I looked around at some posts on here that seemed to deal with similar issues but they all seem to be over my head. I tried one that mentioned changing the userdb (which seemed to have already been changed) in dovecot.conf and the user_query line in dovecot-sql.conf, afterwhich I got a replication error. So obviously I read something wrong and screwed that up, but it is easily fixable.

    Honestly (if you can't tell already) I don't know anything about dovecot and have no clue if what I had read was the right thing or not.

    Ideally I would be able to stick to the scheme as the login, but I am starting to get a headache from messing with this :confused:
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you referring to ISPConfig, or where did you change your username?
  3. arspoetica

    arspoetica New Member

    Oh yeah, sorry, that would probably help wouldn't it.. The custom login option in ISP Config under system / interface config / mail

    And I installed using the multi-server walkthrough in the manual (although I have updated to the newest version since then)

    Also, I can't receive email unless it is sent to the [email protected] address... if mail is sent to the other the server rejects it immediately, bypassing the catch-all I setup

    Edit: I changed the username in email / email mailbox / login. So the email addy field says [email protected] and the login field says
    Last edited: Oct 17, 2012
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There are some issues with that function in the current release, you might have to change the querys in the dovecot-sql.conf file to the ones used in ispconfig 3.0.5

    password_query = SELECT password FROM mail_user WHERE login = '%u' AND disable%Ls = 'n'
    user_query = SELECT email as user, maildir as home, CONCAT('maildir:', maildir, '/Maildir') as mail, uid, gid, CONCAT('*:storage=', quota, 'B') AS quota_rule, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE (login = '%u' OR email = '%u') AND disable%Ls = 'n'
  5. arspoetica

    arspoetica New Member

    Wow, so I actually had seen this in another recent post that you responded to, but I apparently missed the ( )'s. So I assume that that is why I couldn't get it to work. Unfortunately I somehow managed to screw something else up in the minor tweaks that I made to the dovecot.conf and dovecot-sql.conf files or something else I messed up because I get this when I try to run /usr/local/ispconfig/server/

    Last edited: Oct 17, 2012
  6. arspoetica

    arspoetica New Member

    So looking through the forums and finding info about this error as it pertains to other problems is confusing me.. I don't really see how I messed things up so badly and I can't figure out for the life of me how to fix it. Did me messing up the dovecot-sql info screw up the table or did I change something else... :(

    edit: Ok, so this is caused by me updating to the 3.0.5 alpha on a multi-server setup from what I can gather, and the best course of action is to add those unknown columns to the mail servers mysql mail_user table. Is that right? If so then how do I know what the correct table fields are?

    edit my edit: YAY! SOLVED, so Till's response to someone else helped me
    and then I had the same problem with disabledoveadm but found it in the servers mysql table (had to pull out one of my books cus I don't really know sql... at all)

    So THANK YOU Till and Falko! Love you guys!
    Last edited: Oct 17, 2012

Share This Page