currently unable to handle this request. HTTP ERROR 500

Discussion in 'Server Operation' started by osas Oribhabor, Jul 4, 2018.

  1. osas Oribhabor

    osas Oribhabor New Member

    hello..
    everything was going fine and suddenly i tried to access my site i get the HTTP ERROR 500.currently unable to handle this request. HTTP ERROR 500. i run ubuntu 16.04 and its i wordpress site.. bellow is the error log from var/log/apache2/error.log

    Code:
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:36:35.888879 2018] [mpm_prefork:notice] [pid 1752] AH00169: caught SIGTERM, shutting down
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    Error Opening file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:00.216163 2018] [:error] [pid 1683] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:00.911636 2018] [suexec:notice] [pid 1683] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jul 03 20:38:01.298452 2018] [:notice] [pid 1792] FastCGI: process manager initialized (pid 1792)
    [Tue Jul 03 20:38:01.301470 2018] [:error] [pid 1786] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.205917 2018] [:error] [pid 1786] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Tue Jul 03 20:38:02.226907 2018] [:error] [pid 1786] python_init: Python executable found '/usr/bin/python'.
    [Tue Jul 03 20:38:02.226928 2018] [:error] [pid 1786] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Tue Jul 03 20:38:02.226962 2018] [:notice] [pid 1786] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Tue Jul 03 20:38:02.226966 2018] [:notice] [pid 1786] mod_python: using mutex_directory /tmp
    [Tue Jul 03 20:38:02.570209 2018] [:error] [pid 1849] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.576934 2018] [:error] [pid 1850] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.593983 2018] [:error] [pid 1851] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.640886 2018] [:error] [pid 1852] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.646831 2018] [:error] [pid 1849] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.646939 2018] [:error] [pid 1850] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.646948 2018] [:error] [pid 1850] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.646956 2018] [:error] [pid 1850] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.652664 2018] [:error] [pid 1851] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.652674 2018] [:error] [pid 1851] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.652683 2018] [:error] [pid 1851] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.693398 2018] [:error] [pid 1852] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.693410 2018] [:error] [pid 1852] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.693418 2018] [:error] [pid 1852] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.695753 2018] [:error] [pid 1849] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.695777 2018] [:error] [pid 1849] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.706683 2018] [mpm_prefork:notice] [pid 1786] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jul 03 20:38:02.706717 2018] [core:notice] [pid 1786] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jul 03 20:38:02.922961 2018] [:error] [pid 1854] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.923200 2018] [:error] [pid 1854] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.923208 2018] [:error] [pid 1854] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:02.923216 2018] [:error] [pid 1854] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:13.735738 2018] [:error] [pid 2226] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:13.736096 2018] [:error] [pid 2226] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:13.736109 2018] [:error] [pid 2226] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:38:13.736121 2018] [:error] [pid 2226] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:48.527022 2018] [:error] [pid 3299] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:48.527507 2018] [:error] [pid 3299] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:48.527522 2018] [:error] [pid 3299] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:48.527533 2018] [:error] [pid 3299] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.532471 2018] [:error] [pid 3301] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.532802 2018] [:error] [pid 3301] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.532816 2018] [:error] [pid 3301] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.532832 2018] [:error] [pid 3301] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.537308 2018] [:error] [pid 3300] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.537760 2018] [:error] [pid 3300] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.537789 2018] [:error] [pid 3300] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    [Tue Jul 03 20:44:49.537799 2018] [:error] [pid 3300] [mod_geoip]: Error while opening data file /usr/share/GeoIP/GeoLiteCity.dat
    
     
  2. Taleman

    Taleman Active Member HowtoForge Supporter

    Is web server running now? Does that file /usr/share/GeoIP/GeoLiteCity.dat exist?
    is package geoip-database installed?
    Did you install or activate country blocking in wordpress?
     
  3. osas Oribhabor

    osas Oribhabor New Member

    i have turned geoip ennabled off in the geoip.conf file.

    now i get the following errors in my error log
    Code:
    [Tue Jul 03 22:51:21.617612 2018] [:error] [pid 1749] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Tue Jul 03 22:51:21.651883 2018] [:error] [pid 1749] python_init: Python executable found '/usr/bin/python'.
    [Tue Jul 03 22:51:21.651901 2018] [:error] [pid 1749] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Tue Jul 03 22:51:21.651942 2018] [:notice] [pid 1749] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Tue Jul 03 22:51:21.651947 2018] [:notice] [pid 1749] mod_python: using mutex_directory /tmp
    [Tue Jul 03 22:51:22.060672 2018] [mpm_prefork:notice] [pid 1749] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jul 03 22:51:22.060730 2018] [core:notice] [pid 1749] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jul 03 23:08:17.207933 2018] [mpm_prefork:notice] [pid 1749] AH00169: caught SIGTERM, shutting down
    [Tue Jul 03 23:08:18.173715 2018] [suexec:notice] [pid 5755] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jul 03 23:08:18.243721 2018] [:notice] [pid 5761] FastCGI: process manager initialized (pid 5761)
    [Tue Jul 03 23:08:18.342376 2018] [:error] [pid 5757] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Tue Jul 03 23:08:18.342552 2018] [:error] [pid 5757] python_init: Python executable found '/usr/bin/python'.
    [Tue Jul 03 23:08:18.342562 2018] [:error] [pid 5757] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Tue Jul 03 23:08:18.342606 2018] [:notice] [pid 5757] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Tue Jul 03 23:08:18.342614 2018] [:notice] [pid 5757] mod_python: using mutex_directory /tmp
    [Tue Jul 03 23:08:18.364493 2018] [mpm_prefork:notice] [pid 5757] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jul 03 23:08:18.364525 2018] [core:notice] [pid 5757] AH00094: Command line: '/usr/sbin/apache2'
    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 5.
    [Tue Jul 03 23:14:26.861009 2018] [mpm_prefork:notice] [pid 5757] AH00169: caught SIGTERM, shutting down
    [Tue Jul 03 23:14:27.875598 2018] [suexec:notice] [pid 6201] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jul 03 23:14:27.939604 2018] [:notice] [pid 6207] FastCGI: process manager initialized (pid 6207)
    [Tue Jul 03 23:14:28.030405 2018] [:error] [pid 6203] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Tue Jul 03 23:14:28.030539 2018] [:error] [pid 6203] python_init: Python executable found '/usr/bin/python'.
    [Tue Jul 03 23:14:28.030545 2018] [:error] [pid 6203] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Tue Jul 03 23:14:28.030576 2018] [:notice] [pid 6203] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Tue Jul 03 23:14:28.030580 2018] [:notice] [pid 6203] mod_python: using mutex_directory /tmp
    [Tue Jul 03 23:14:28.052071 2018] [mpm_prefork:notice] [pid 6203] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jul 03 23:14:28.052125 2018] [core:notice] [pid 6203] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jul 03 23:21:31.417857 2018] [mpm_prefork:notice] [pid 6203] AH00169: caught SIGTERM, shutting down
    [Tue Jul 03 23:22:55.239989 2018] [suexec:notice] [pid 1666] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jul 03 23:22:55.611302 2018] [:notice] [pid 1784] FastCGI: process manager initialized (pid 1784)
    [Tue Jul 03 23:22:56.468009 2018] [:error] [pid 1778] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Tue Jul 03 23:22:56.490630 2018] [:error] [pid 1778] python_init: Python executable found '/usr/bin/python'.
    [Tue Jul 03 23:22:56.490648 2018] [:error] [pid 1778] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Tue Jul 03 23:22:56.490681 2018] [:notice] [pid 1778] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Tue Jul 03 23:22:56.490685 2018] [:notice] [pid 1778] mod_python: using mutex_directory /tmp
    [Tue Jul 03 23:22:56.737127 2018] [mpm_prefork:notice] [pid 1778] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jul 03 23:22:56.737164 2018] [core:notice] [pid 1778] AH00094: Command line: '/usr/sbin/apache2'
    Argument ""-"" isn't numeric in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 4.
    [Tue Jul 03 23:48:04.677720 2018] [mpm_prefork:notice] [pid 1778] AH00169: caught SIGTERM, shutting down
    [Tue Jul 03 23:48:05.643500 2018] [suexec:notice] [pid 4085] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jul 03 23:48:05.703658 2018] [:notice] [pid 4091] FastCGI: process manager initialized (pid 4091)
    [Tue Jul 03 23:48:05.792368 2018] [:error] [pid 4087] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Tue Jul 03 23:48:05.792468 2018] [:error] [pid 4087] python_init: Python executable found '/usr/bin/python'.
    [Tue Jul 03 23:48:05.792472 2018] [:error] [pid 4087] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Tue Jul 03 23:48:05.792493 2018] [:notice] [pid 4087] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Tue Jul 03 23:48:05.792497 2018] [:notice] [pid 4087] mod_python: using mutex_directory /tmp
    [Tue Jul 03 23:48:05.809254 2018] [mpm_prefork:notice] [pid 4087] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jul 03 23:48:05.809303 2018] [core:notice] [pid 4087] AH00094: Command line: '/usr/sbin/apache2'
    [Wed Jul 04 03:34:24.203905 2018] [mpm_prefork:notice] [pid 4087] AH00169: caught SIGTERM, shutting down
    [Wed Jul 04 03:34:25.197601 2018] [suexec:notice] [pid 14216] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Wed Jul 04 03:34:25.255169 2018] [:notice] [pid 14222] FastCGI: process manager initialized (pid 14222)
    [Wed Jul 04 03:34:25.348365 2018] [:error] [pid 14218] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Wed Jul 04 03:34:25.350761 2018] [:error] [pid 14218] python_init: Python executable found '/usr/bin/python'.
    [Wed Jul 04 03:34:25.350773 2018] [:error] [pid 14218] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Wed Jul 04 03:34:25.350815 2018] [:notice] [pid 14218] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Wed Jul 04 03:34:25.350820 2018] [:notice] [pid 14218] mod_python: using mutex_directory /tmp
    [Wed Jul 04 03:34:25.377823 2018] [mpm_prefork:notice] [pid 14218] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal operations
    [Wed Jul 04 03:34:25.377860 2018] [core:notice] [pid 14218] AH00094: Command line: '/usr/sbin/apache2'
    
     
  4. Taleman

    Taleman Active Member HowtoForge Supporter

    Have you modified that file?
    What has been changed on that host since it worked OK last time?
    And: Is apache running now?
     
  5. osas Oribhabor

    osas Oribhabor New Member

    nothing changed to my understanding, i was working on my site and slept off, only to return to see http error 500
     

Share This Page