CSS and JavaScript errors in FireFox

Discussion in 'General' started by pjdevries, Mar 3, 2008.

  1. pjdevries

    pjdevries New Member HowtoForge Supporter

    I am using FireFox 2.0.0.12 as my primary browser and I am experiencing a lot of warnings and occasional errors when running ISPConfig. I don't have those warnings and errors when running other web applications.

    The warnings mostly concern css related messages, like:
    • Error in parsing valu for property 'border'. Declaration dropped.
    • Unexpected end of file while searching for closing } of invalid rule set.
    • Unknown property 'sctollbar-arrow-color'. Declaration dropped.
      etc.
    Many times an error occurs which prevents the page from being displayed properly. More specifically the tree menu is not displayed at all. The error message is:
    linkFarbe is not defined​
    and after clearing the FireFox messages, it is usually the second message after the warning
    Error in parsing valu for property 'border'. Declaration dropped.​
    The error seems to triggered by a line in JavaScript function maleMenu()
    Code:
    function maleMenu() {
            var menuFrame = self.frames["menuFrame"];
            ausgabeFrame = menuFrame.window.document;
            ausgabeFrame.open("text/html");
            <!-- Bitte die folgende Zeile als Copyright-Hinweis nicht loeschen //-->
            ausgabeFrame.write("<HTML>\n<HEAD>\n\n");
            [COLOR="Red"]ausgabeFrame.write("<STYLE>\n<!--\nA {text-decoration: none}\nA {color: " + [B]linkFarbe[/B] + "}\nA:hover {color: " + aLinkFarbe + "}\nBODY{ [/COLOR]scrollbar-arrow-color: white\;\nscrollbar-base-color: #E0E0E0   }\n-->\n</STYLE>\n");
                    ausgabeFrame.write("</HEAD>\n<BODY BGCOLOR=\"" + hintergrundFarbe + "\" BACKGROUND=\"" + hintergrundBild + "\" LINK=\"" + linkFarbe + "\" ALINK=\"" + aLinkFarbe + "\" VLINK=\"" + bLinkFarbe + "\" topmargin=\"10\" leftmargin=\"10\">\n");
            ausgabeFrame.write("<FONT FACE=\"" + MenuSchrift + "\" SIZE=" + MenuSchriftGroesse + " COLOR=\"" + textFarbe + "\">\n");
            ausgabeFrame.write(prefixHTML);
    ...
    ...
    ...
    }
    Is this a known problem and is there a solution for it?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I'am using firefox too and I did not notice any javascript errors yet. I will have a lokk in which cases this error may occur.
     
  3. pjdevries

    pjdevries New Member HowtoForge Supporter

    Very much appreciated. Chances are it has something to do with my FireFox configuration and not with ISPConfig, but I don't know where to start looking.
     
  4. pjdevries

    pjdevries New Member HowtoForge Supporter

    For your information: I just disabled all the FireFox add-ons but the problem persists.
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  6. pjdevries

    pjdevries New Member HowtoForge Supporter

    I use Firebug a lot to debug my html and css code, but how can it help me in finding more warnings or erros then the ones I reported in my first post?

    Firebug reports the same error as the one I see in the standard Firefox error console: linkFarbe is not defined. The complete Firebug message is this:

    inhalt_tree.php (line 34)

    linkFarbe is not defined
    maleMenu()inhalt_tree.php (line 34)
    neumalen()inhalt_tree.php (line 114)
    onresize(resize )inhalt_tree.php (line 1)
    ausgabeFrame.write("<STYLE>\n<!--\nA {text-decoration: none}\nA {color: ...​
    Is that of any help?
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I'm not sure where these errors are coming from, but maybe ISPConfig isn't installed properly because your disk is full? What's the output of
    Code:
    df -h
    ?
     
  8. pjdevries

    pjdevries New Member HowtoForge Supporter

    It may have something to do with ISPConfig being not properly installed, but that has nothing to do with available diskspace. The output of df -h:
    Filesystem Size Used Avail Use% Mounted on
    simfs 100G 5.0G 96G 5% /
    tmpfs 1012M 0 1012M 0% /lib/init/rw
    tmpfs 1012M 4.0K 1012M 1% /dev/shm
    More diskspace than money :D

    Two extra bits of information:
    • I have the same problem on two different machines, running two different editions of Windows Vista Ultimate (one 32 bit and one 64 bit) but the same version of Firefox.
    • Last weekend I updated ISPConfig from version 2.2.14 to 2.2.21. The problem was already there before the update and is still there after the update.
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I don't have a Vista system, and I've never seen that behaviour on other operating systems. Do you have an XP or Linux machine to test this? Unlikely, but maybe it's a Vista problem?
     
  10. pjdevries

    pjdevries New Member HowtoForge Supporter

    I'll try it on both an XP and a Linux system tomorrow and let you know what happens.
     
  11. cvladan

    cvladan New Member

    Same problem, but solved

    I have a same problem for a while. It is exclusively Firefox problem, and it's not happening in Internet Explorer. It's really annoying (Vista).

    Anyway, the reason is probably (that's what I think) because Firefox triggers on resize event for no apparent reason, and it happens before any other JavaScript on the page.

    The solution that worked for me is just to remove the maleMenu() call from neumalen() function. Basically, neumalen() function now has no meaning (and as I see it, it was only for onresize).

    Please, check this in more detail and patch the code accordingly.

    Best regards
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thanks, I added it to the bugtracker.
     

Share This Page