Cronjobs dont work

Discussion in 'Installation/Configuration' started by Stown, Jun 22, 2011.

  1. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Hi all,

    First of all, I use ISPconfig 3.0.3.3 on a debian lenny 64bit server.

    I have the idea that the cronjobs that i add through the control panel dont work or or that they on the background dont run.

    Also have i some external pop retrievers active (fetchmail) and since a couple days they dont work anymore. I think this has something to do with the cronjobs as they run per hour or so.

    Does anyone know how to trigger this cronjob issue?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you get any cron related errors in your syslog? Is the ispconfig monitor still up to date, or are the infos there a few days old?
     
  3. Stown

    Stown ISPConfig Developer ISPConfig Developer

    tail /var/log/syslog gives the following output: (filtered on just cron related messages)

    Jun 22 06:26:01 server1 /USR/SBIN/CRON[23065]: (web39) CMD (/usr/bin/php /var/www/clients/client1/web39/web/Pro/cronjob.php)
    Jun 22 06:26:01 server1 /USR/SBIN/CRON[23067]: (web37) CMD (/usr/bin/php /var/www/clients/client1/web37/web/cron/online.php)
    Jun 22 06:26:01 server1 /USR/SBIN/CRON[23064]: (web37) CMD (/usr/bin/php /var/www/clients/client1/web37/web/cron/cammers.php)
    Jun 22 06:26:01 server1 /USR/SBIN/CRON[23068]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)

    on the monitor page in the system log tab i see only this:
    Jun 22 10:55:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:00:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:00:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:05:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:05:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:10:02 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:10:02 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:15:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:15:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:20:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:20:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:25:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:25:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:30:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:30:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:35:02 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:35:02 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:40:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:40:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:45:02 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:45:02 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:50:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:50:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
    Jun 22 11:55:01 server1 pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Jun 22 11:55:01 server1 pure-ftpd: ([email protected]) [INFO] Logout.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so according to syslog, cron is running. Are these fetchmail jobs that stopped working jobs that you created inside ispconfig or did you create them manually?
     
  5. Stown

    Stown ISPConfig Developer ISPConfig Developer

    No, i added the fetchmail account through ispconfig at email page on the tab fetchmail.
    And when i look at the monitor page and then the email queue tab i see this:
    Data vanaf: 2011-06-22 13:50
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    9B09658800A* 640 Wed Jun 22 13:50:01 [email protected]
    [email protected]

    42A6458801C 3549 Wed Jun 22 02:48:34 MAILER-DAEMON
    (Host or domain name not found. Name service error for name=nnws.net type=MX: Host not found, try again)
    [email protected]

    -- 4 Kbytes in 2 Requests.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Do you have working nameservers in /etc/resolv.conf?
     
  7. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Yes, nameserver works!
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Pölease post the output of the following command issued on the shell of your server:

    ping -c 1 nnws.net
     
  9. Stown

    Stown ISPConfig Developer ISPConfig Developer

    server1:~# ping -c 1 nnws.net
    ping: unknown host nnws.net
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

  11. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Hm.. the nameserver on my server looks good as when i do "telnet (nameserver IP) 53" it works like it supposed to.

    What could be the problem?

    Thanks for you'r help by the way :)
     
  12. pititis

    pititis Member

    nnws.net is dead or down.

    Cheers
     
  13. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Till, i think there is a bug with the cronjobs. I tried everything.

    The jobs don't run even when i see them on the right times in the syslog.

    The problem is the chrooted environment i think.

    I have made a workaround.

    1. install webmin.
    2. login through webmin and change the cronjobs from user:webxx to user:root.

    And then the cronjobs work succesfully!
     

Share This Page