Cronjobs dont seem to be firing

Discussion in 'General' started by chaloum, Mar 20, 2012.

  1. chaloum

    chaloum New Member

    I've got some cron jobs setup in ISPConfig which don't seem to get triggered. I also dont see any thing in the ISPC Cron-log

    I also setup set up some job in the /var/spool/cron they also dont seem to get triggered.


    Any ideas on how to get the cron jobs working. There is another issue with cron jobs and Drupal but I'll take that up later


    thanks
     
  2. till

    till Super Moderator

    The ispconfig cron log is for the ispconfig server.sh cronjob only. Normal cronjobs like user cronjobs are logged to the syslog.

    Did you create a jailed cronjob? If yes, you might want to check if the executed application is in the jail and that the path is local to the jail.
     
  3. chaloum

    chaloum New Member

    i got the corn working as root

    I got the cron working as root, I couldn't gat any of the others to work.

    Does the server run any jobs?

    because there is nothing in the ISPC Cron log in ISPConfig
     
  4. till

    till Super Moderator

    If the cronjobs run as root, then cron is working fine and its a problem with the script or commands that you run. See my description above about jails.

    That indicates that everything is working fine, as this log would contain only errors. and the log is not relecvant for your problem anyway, I explained that above.
     
  5. chaloum

    chaloum New Member

    does ISPConfig run any cron jobs of its own?

    that may be the case but does ISPConfig run any cron jobs of its own?

    so cron jobs set up in IPSConfig that have errors would show up in the ISPC Cron log?
     
    Last edited: Mar 21, 2012

Share This Page