Cronjob not working

Discussion in 'General' started by icinfo, Aug 10, 2011.

  1. icinfo

    icinfo New Member

    We're having ISPConf 3.0.3.3. and trying to add cronjob command to the website. The cronjob does not do anything when placed to ISPCOnf but works when put directly as a command.

    Definitions for times are:

    Minutes: 10
    all other time-definations: *

    Cronjob site address in the Cronjob comman definitions:

    http://sitename.com/administrator/components/com_csvivirtuemart/helpers/cron.php username="xxx" passwd="xxx" template_id="16"

    Is it possible this problem has something to do with the ISPConf settings/configuration? Any ideas?

    Amy
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact command that you entered into the command field in the cronjob settings.
     
  3. SamTzu

    SamTzu Member HowtoForge Supporter

    We have tried it both ways...

    Straight from the command line this works...

    Also tried...

    Neither worked unless run straight from command line. :confused:
     
  4. SamTzu

    SamTzu Member HowtoForge Supporter

    This is the command we would like to run but it's rather long. :)

     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be that the command is too long. Check the command that is stored in the cront file in /etc/cron.d if it is complete.
     
  6. SamTzu

    SamTzu Member HowtoForge Supporter

    I think I found the problem. (OpenVZ client)

    Jail kit gives this error when I try to upgrade it.
    This probably messes up the users cron.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not a problem, as insserv calculates the dependencies automatically. Beside that, the jailkit daemon part is not used in your setup, so it does not matter if it is started or not.
     
  8. SamTzu

    SamTzu Member HowtoForge Supporter

    I can't figure out what the problem is.
    This line keeps poping up in the syslog...

    Clearly the user cron job does not run.

    Must be a bug somewhere. I wonder if this is also true in Debian?
    http://ubuntuforums.org/showthread.php?t=1760488

     
    Last edited: Aug 19, 2011
  9. SamTzu

    SamTzu Member HowtoForge Supporter

    And the log file reveals the reason...

    For some reason there is no bash in the users bin folder.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if the jail is broken or has not been fully initialized with all required files. The jail is only created once for every website when the first cronjob or shell user is created.
     
  11. SamTzu

    SamTzu Member HowtoForge Supporter

    I concur.
    Probably OpenVZ related.
    I hope that LXC will soon replace that old problem child. :(

    Where is the jailkit skeleton?

     
    Last edited: Aug 19, 2011
  12. SamTzu

    SamTzu Member HowtoForge Supporter

    Puzzle continues.
    I have tracked the problem to this...
    On OpenVZ server s1 this works but on other OpenVZ server it does not.
    Both are Debian Squeeze servers.
    Looks like something is missing there that some how relates to dh_testdir.

     

Share This Page