Cron via ISPConfig fails, crontab -e works

Discussion in 'General' started by bidevi, Apr 25, 2010.

  1. bidevi

    bidevi New Member

    I have tried to set up a cron job using the ISPConfig3 panel. Nothing happened.

    Setting it up with crontab -e worked flawlessly.

    I guess I'm not doing it right. The line in crontab -e is:

    */2 * * * * /usr/bin/wget -O - -q -t 1

    In ISPConfig3 I put */2 for minute et cetera and in the Command field I put:

    /usr/bin/wget -O - -q -t 1

    What could I be doing wrong?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The cronjobs in ispconfig are jailed. You should check if the wget binary is also available in the jail.
  3. bidevi

    bidevi New Member

    Till, your answer raises more questions. I followed the steps for installing Lenny + ISPConfig3, so if this kind of setup allows the use of wget, the answer is yes. I don't know that, I'm not that Linux savvy. So what I like to know now is:

    1. Is wget jailed with the perfect set-up of Lenny + ISPConfig3
    2. How can I check for myself whether wget is jailed?
    3. If wget is jailed, what else can I use? Curl of sh?

    Thanx in advance for your answers.

Share This Page