Cron tasks not executing

Discussion in 'Installation/Configuration' started by Stelios, Sep 18, 2020.

  1. Stelios

    Stelios Member

    Hi all,
    I've finished a multi server setup and added one domain/email/db and everything worked fine.
    After a day I've added another one, emails etc and nothing is been executed. The queue (red top icon) stays forever with:

    The following changes are not yet populated to all servers:
    • Create DNS record: 8
    • datalog_status_i_dns_slave: 1
    • Create DNS zone: 1
    • Update DNS zone: 2
    • Create email domain: 1
    • Create email user: 1
    • Update email user: 1
    • Create spam filter settings: 2
    • Create new website: 1
    • Update website settings: 2

    I've tried so far to disable cron and run it manually (/usr/local/ispconfig/server/cron.sh) and runs without any error.

    How can I troubleshoot this?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Stelios

    Stelios Member

    I've read already that and logs showing no errors
     
  4. Stelios

    Stelios Member

    I was running the command only to the control panel server where it needs to the rest as well.
    This is what I'm getting on the rest of the servers:

    Code:
    18.09.2020-16:39 - WARNING - There is already a lockfile set, but no process running with this pid (2836). Continuing.
    PHP Warning:  mysqli_real_connect(): (HY000/1045): Access denied for user 'ispcsrv4'@'myIP' (using password: YES) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 85
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This means you either closed the mysql port on master or configured mysql on master to not listen on the external interface anymore or the /etc/hosts setup on master and slaves is not correct (see multiserver install guides for correct hostname configuration) so that slaves can't authenticate on master anymore
     
  6. Stelios

    Stelios Member

    Till thank you very much. I had:
    skip-name-resolve in my.cnf.
    Removing it worked.

    Do you aware of how I can make it work without removing the skip-name-resolve?

    My hosts file has all the hostnames & IPs of the multi server setup.

    Thanks a lot
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Name resolving is required, so don't deactivate that.
     
  8. Stelios

    Stelios Member

    What about if I leave it on the controlpanel server but I use it on my DB servers? It should work?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    That might work, but you'll have to try it as logins from localhost might fail then as well and probably none of your websites will be able to authenticate themself on the db server then.
     

Share This Page