Cron emails to 'nobody'

Discussion in 'Installation/Configuration' started by ADM, Apr 23, 2007.

  1. ADM

    ADM ISPConfig Developer ISPConfig Developer

    ISPConfig v2.2.11 on Debiag v4.0rc2 (etch) with Perfect Setup:

    I would like to point that I notice some emails sent to 'nobody' user

    This is my /var/mail/nobody
    Code:
    From [email protected]  Sat Apr  7 06:25:04 2007
    Return-Path: <[email protected]>
    X-Original-To: root
    Delivered-To: [email protected]
    Received: by myhost.mydomain.net (Postfix, from userid 0)
            id 770494F8D1; Sat,  7 Apr 2007 06:25:04 +0200 (CEST)
    From: [email protected] (Cron Daemon)
    To: [email protected]
    Subject: Cron <[email protected]> test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
    Content-Type: text/plain; charset=ISO-8859-15
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin>
    X-Cron-Env: <HOME=/root>
    X-Cron-Env: <LOGNAME=root>
    Message-Id: <[email protected]>
    Date: Sat,  7 Apr 2007 06:25:02 +0200 (CEST)
    
    /etc/cron.daily/man-db:
    mandb: can't set the locale; make sure $LC_* and $LANG are correct
    /etc/cron.daily/sysklogd:
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = (unset),
            LC_ALL = (unset),
            LANG = "it_IT.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = (unset),
            LC_ALL = (unset),
            LANG = "it_IT.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    

    This is the realated /var/log/mail.log piece
    Code:
    Apr 23 06:25:02 mega postfix/pickup[2754]: B45794F8D3: uid=0 from=<root>
    Apr 23 06:25:02 mega postfix/cleanup[4065]: B45794F8D3: message-id=<[email protected]>
    Apr 23 06:25:02 mega postfix/qmgr[30454]: B45794F8D3: from=<[email protected]>, size=1249, nrcpt=1 (queue active)
    Apr 23 06:25:02 mega postfix/local[4067]: B45794F8D3: to=<[email protected]>, orig_to=<root>, relay=local, delay=0.53, delays=0.44/0/0/0.08, dsn=2.0.0, stat
    us=sent (delivered to command: procmail -a "$EXTENSION")
    Apr 23 06:25:02 mega postfix/qmgr[30454]: B45794F8D3: removed
    

    The servername is myhost.mydomain.net so the email goes to [email protected]

    What I'm asking is:

    1. Is there any way to track why emails to [email protected] goes to 'nobody' ?

    2. What is the best way to tell the system to send root's email to [email protected] ?


    Thanks a lot.

    P.S. Any hint also to solve the
    Code:
    check that your locale settings:
            LANGUAGE = (unset),
            LC_ALL = (unset),
            LANG = "it_IT.UTF-8
    
    issue?
     
  2. Hawker

    Hawker New Member

    Define who should get root's email in /etc/aliases. And be sure to run newaliases after changing that file.
     
  3. ADM

    ADM ISPConfig Developer ISPConfig Developer

    I have this /etc/aliases
    Code:
    # See man 5 aliases for format
    postmaster:    root
    
    Do you mean to edit in something like
    Code:
    postmaster:    root
    root: "[email protected]"
    
    ?
     
  4. Hawker

    Hawker New Member

    At the very end of the file there should be somthing that looks like this...

    Code:
    # Person who should get root's email
    root:       root
    Change it to..
    Code:
    # Person who should get root's email
    root:       [email protected]
    Do not use quotes around the address.
     

Share This Page