Critical: Reset Root Login

Discussion in 'General' started by YamiHoshi, Jul 27, 2010.

  1. YamiHoshi

    YamiHoshi New Member

    Solved: Reset Root Login

    It seems that someone played around with my ISPConfig installation.
    Now I can't seem to login on either ISPConfig, nor phpMyAdmin.
    I know I can reset login count through phpMyAdmin (I know that from my days in a webhosting company), but I also don't seem to be able to login on that.
    MySQL hasn't been hacked, I can still login on MySQL through SSH.

    So I want to know this:
    What do I have to do, so I can login on phpMyAdmin?
    If that's done, I know the rest.

    Thanks in advance.
     
    Last edited: Jul 27, 2010
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  3. YamiHoshi

    YamiHoshi New Member

    I can't seem to stop MySQL.
    Code:
    [root@client319 mysql]#/etc/init.d/mysqld stop
    Stoppen van MySQL:                                         [MISLUKT]
    [root@client319 mysql]#mysql -p
    Enter password: 
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 2847
    Server version: 5.0.77 Source distribution
    
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    
    mysql> update user set Password=PASSWORD('***************') WHERE User='root';
    ERROR 1046 (3D000): No database selected
    mysql> quit
    Bye
    [root@client319 mysql]#
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please follow the steps in the tutorial exactly. The command to connect to mysql is:

    mysql -u root mysql

    and not:

    mysql -p
     
  5. YamiHoshi

    YamiHoshi New Member

    I know that.
    But like I said before, I can't stop MySQL.
    If I can't stop it, logging in without "-p" is useless.

    Update:
    I'm in!
    I just used the wrong IP address.
    D'oh!

    Update2:
    Finding the failed login count is harder then I thought (I used Kloxo at the Webhosting Company).
    Where is it?

    Update3:
    Sorry for this, it seems I just confused 'admin' with 'root'.
    Well, problem solved.
     
    Last edited: Jul 27, 2010

Share This Page