creating zone multiple sites

Discussion in 'Installation/Configuration' started by axtoxic107, Jun 6, 2010.

  1. axtoxic107

    axtoxic107 New Member

    Hello,

    I am using bind9 and on linux debian 5..
    Previously after much of the headache (in setting namesever) i was able to get one of my site online..Now i want my other site to work and i am not able to make it work.

    Previously i have only one master record but for now to make my second site work i have created two master record..

    Code:
    ;
    ; BIND data file for example.com
    ;
    $TTL    604800
    @       IN      SOA     ns1.example.com. info.example.com. (
                                2007011501         ; Serial
                                      7200         ; Refresh
                                       120         ; Retry
                                   2419200         ; Expire
                                    604800)        ; Default TTL
    ;
    @       IN      NS      ns1.example.com.
    @       IN      NS      ns2.example.com.
    example.com.    IN      MX      10      mail.example.com.
    example.com.    IN      A       192.168.254.1
    ns1                     IN      A       192.168.254.1
    ns2                     IN      A       192.168.254.2
    www                     IN      CNAME   example.com.
    mail                    IN      A       192.168.254.1
    ftp                     IN      CNAME   example.com.
    example.com.            IN      TXT     "v=spf1 ip4:192.168.254.1 a mx ~all"
    mail                    IN      TXT     "v=spf1 a -all"
    
    I have just replace the example.com with example2.com and save it
    So now i have two files..
    1. example.com.db
    2. example2.com.db

    Now while setting up the reverse DNS, i have notice its name was like this..
    "192.168.254.rev"
    So, i thought it will not work if i create two files here so i pasted the code two time one for example.com and other for example2.com (i dont know i can do this or not)

    So my revere DNS files looks like this now

    Code:
    $TTL 1d ;
    $ORIGIN 254.168.192.IN-ADDR.ARPA.
    @       IN      SOA     ns1.example.com.   info.example.com. (
                                           2007011501
                                           7200
                                           120
                                           2419200
                                           604800
    )
            IN      NS      ns1.example.com.
            IN      NS      ns2.example.com.
    1       IN      PTR     ns1.example.com.
    2       IN      PTR     ns2.example.com.
    
    
    $TTL 1d ;
    $ORIGIN 254.168.192.IN-ADDR.ARPA.
    @       IN      SOA     ns1.example2.com.   info.example2.com. (
                                           2007011502
                                           7200
                                           120
                                           2419200
                                           604800
    )
            IN      NS      ns1.example2.com.
            IN      NS      ns2.example2.com.
    1       IN      PTR     ns1.example2.com.
    2       IN      PTR     ns2.example2.com.
    
    
    But i am not getting to run this command
    nslookup
    ns1.example2.com

    it returning to me
    ;; Got SERVFAIL reply from 66.96.208.21, trying next server
    ;; Got SERVFAIL reply from 66.96.208.21, trying next server
    ;; Got SERVFAIL reply from 64.191.100.61, trying next server
    Server: 64.191.100.53
    Address: 64.191.100.53#53



    Please help....
     
  2. falko

    falko Super Moderator

Share This Page