Creating website - nothing happens

Discussion in 'Installation/Configuration' started by hagel, Aug 6, 2005.

  1. hagel

    hagel New Member

    I'm creating a new website in ISPConfig, and everything seems fine in ISPConfig but after checking around it seems no new dir was made for the site neither was anything added to Vhosts_ispconfig.conf

    Anyone have any idéas??
     
  2. falko

    falko Super Moderator

    Did you adjust the values in the table isp_server in your MySQL database to your system?
     
  3. hagel

    hagel New Member

    I did that, all values are correct, to the best of my knowledge..

    Can't find anything wrong actually, any idéas?

    Can you perhaps alter which group:user that should create directories and or alter Vhosts_ispconfig.conf ?? Right now it is root:root that owns the conf file, root also owns /var/www if that matters..

    Cheers
     
  4. hagel

    hagel New Member

    oh, btw, is it really apache that is supposed to create dirs etc? Or is there a cron job somewhere that hasn't been started?
     
  5. till

    till Super Moderator

    The dirs and users are not created by apache, it is a script (ispconfig_wconf) that is started by the /etc/init.d/ispconfig_server script together with the apache on port 81.
    Did you have any errors in the ispconfig log?

    Code:
    /home/admispconfig/ispconfig/ispconfig.log
     
  6. hagel

    hagel New Member

    gah... That script doesn't exist.. I started ISPConfig's apache manually..
     
  7. hagel

    hagel New Member

    found the script, copied it to /etc/init.d/

    seems to work a bit better now..
     
  8. hagel

    hagel New Member

    Now the directories are correctly set up etc, but no entries are made in Vhosts_ispconfig.conf - but a copy is made of the file.
     
  9. hagel

    hagel New Member

    This is the errors found in the log:

    Code:
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1020: cp -fr /root/ispconfig/isp/error_en /var/www/web7/web/error
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1060: ln -s /var/www/web7 /var/www/setup.grub.se
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 92: setquota -g web7 10240 10240 0 0 -a &> /dev/null
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 113: Connected successfully
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 208: MySQL FLUSH PRIVILEGES
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 136: cp -fr /etc/mail/sendmail.cw /etc/mail/sendmail.cw
    ~
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 283: cp -fr /etc/postfix/virtual_maps /etc/postfix/virt
    ual_maps~
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 288: postmap hash:/etc/postfix/virtual_maps
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line
     1181: cp -fr /etc/apache2/conf/vhosts/Vhosts_ispconfig.conf /etc/apache2/conf/vhosts/Vhosts_ispconfig.conf~
    07.08.2005 - 13:14:17 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1786: WARNING: could not httpd -t &> /dev/null
    07.08.2005 - 13:14:17 => INFO - HTTPD_SYNTAX_CHECK: suexec
    07.08.2005 - 13:14:17 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2327: WARNING: could not httpd -t  &> /dev/null
    07.08.2005 - 13:14:17 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2333: httpd syntax seems to contain errors, reloading with old configurati
    on
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2334: mv -f /etc/apache2/conf/vhosts/Vhosts_ispconfig.conf /etc/apache2/co
    nf/vhosts/Vhosts_ispconfig.conf_07-08-05_13-14-17
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2335: mv -f /etc/apache2/conf/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/c
    onf/vhosts/Vhosts_ispconfig.conf
    07.08.2005 - 13:14:17 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/apache reload &> /dev/null
    07.08.2005 - 13:14:18 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix stop &> /dev/null
    07.08.2005 - 13:14:18 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix start &> /dev/null
    07.08.2005 - 13:14:18 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1811: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
    
    note, httpd is not how I start/stop apache, I have /etc/init.d/apache2
     
  10. falko

    falko Super Moderator

  11. hagel

    hagel New Member

    php is installed, both for my main apache install and for ISPConfig.

    Since the web (ISPConfig) works like it should, except for the writing issue, I guess PHP is in order there.
     
  12. falko

    falko Super Moderator

    The ISPConfig Apache is not the problem, my post is related to your main Apache. Make sure that it loads all needed modules like PHP, mod_rewrite, Perl, etc.
     
  13. hagel

    hagel New Member

    Ok, checked my apache2.conf and it loads alot of modules, like mod_rewrite and mod_php4 for example, perl on the other hand isn't loaded, but I know it is installed, since I used it yesterday.. hmm, cant find module_perl.so anywhere..
     
  14. hagel

    hagel New Member

    Hmpf.. tried to compile perl, but perl wanted to satisfy dependency to apache 1.3 ... gah..
     
    Last edited: Aug 7, 2005

Share This Page