Creating of databases stop working

Discussion in 'General' started by binaryrogue, Nov 24, 2009.

  1. binaryrogue

    binaryrogue New Member

    I am not able to create any databases even though it shows up in ispconfig. Looking at the ispconfig.log file, the last entries was back in May 2009. It showed a lot of errors while dropping multiple databases, errors dropping users and so on.

    What can be causing this? Are there any other logs to see what ispconfig is doing when attempting to create the database?

    I rebooted both ispconfig servers but still no luck. I have a multiserver setup but the second ispconfig server only does dns.

    I'm running version 3.0.1.1
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the job processing was halted due to a fatal error to avaoid any damage of your setup. Please take a look in the system log in the ispconfig monitor and post the error that you get there. Also take a look at the jobqueue and post which action is causing the system to stop.
     
  3. binaryrogue

    binaryrogue New Member

    It doesn't show anything in the system logs. Is it because I use Fedora?

    Here's the output of job queue:
    ===
    2009-11-23 23:20 ispc1.domain.com Insert web_database
    2009-11-23 22:46 ispc1.domain.com Insert web_database
    2009-11-23 22:46 ispc1.domain.com Delete web_database
    2009-11-23 22:42 ispc1.domain.com Update web_database
    2009-11-23 22:42 ispc1.domain.com Update web_database
    2009-11-23 22:38 ispc1.domain.com Insert web_database
    2009-11-23 22:36 ispc1.domain.com Delete web_database
    2009-11-23 22:23 ispc1.domain.com Insert web_database
    2009-11-23 22:23 ispc1.domain.com Delete web_database
    2009-11-23 22:05 ispc1.domain.com Insert web_database
    ===

    Is web_database just a name for inserting into the main database or the creating of the database?
     
  4. binaryrogue

    binaryrogue New Member

    I just notice now... nothing shows up in Monitoring for my Main ispconfig server. If I click on the second server from the menu, i see all the logs, system logs, maillogs , etc..,

    Looking at the system logs from the console itself /var/log/messages, I see a few of these:

    Nov 23 22:21:51 ispc1 mydns[2212]: 2.0.0.10.in-addr.arpa.: error loading SOA: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)

    Nov 23 22:29:12 ispc1 mydns[2212]: 33.168.192.in-addr.arpa.: error loading SOA: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)
     
    Last edited: Nov 24, 2009
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    There was a bug in older ispconfig releases regarding the logging issue which was solved in 3.0.1.6.

    Regarding the original problem. Please post the errors that you got on the server wehere your databases should be created and then check the monitor if the first job is locked (the first by date, you have to go to the last page in the list to see it as they are listed chronologically).
     
  6. binaryrogue

    binaryrogue New Member

    Are you talking about the Job queue? The first entry on Page 4 shows:

    2009-11-20 13:28 ispc1.domain.com Update dns_soa

    This date was 3 days ago. Does this mean, this entry has not been executed yet?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. Everything shown in the jobqueue is pending. Adn what about my other questions?
     
  8. binaryrogue

    binaryrogue New Member

    I'm not sure what errors you're about Till. When I create the database, it shows up in ispconfig like it was there.

    If I click on Monitor and try to view the main server (ispc1), all stats and log shows:


    Data from: ????-??-?? ??:??
    No data about the disk usage available at the moment. Please check again later.

    Before, it would always show the logs and such.
     
    Last edited: Nov 24, 2009
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Run this command as root user (dont use sudo) on the shell of every server and post the output:

    /usr/local/ispconfig/server/server.sh
     
  10. binaryrogue

    binaryrogue New Member

    [[email protected] ~]# /usr/local/ispconfig/server/server.sh
    PHP Warning: Module 'fileinfo' already loaded in Unknown on line 0
    /sbin/mdadm
    /usr/bin/fail2ban-client
    finished.

    ===========

    [[email protected] ~]# /usr/local/ispconfig/server/server.sh
    finished.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok so far. Is the jobqueue empty now?
     
  12. binaryrogue

    binaryrogue New Member

    yea, the queue is now empty. nice.
    So, I went ahead and created the database again:

    here's the queue after 5 mins:
    2009-11-24 00:37 ispc1.domain.com Insert web_database

    Is something still stuck? Usually it takes like a min or so correct to create the database?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if no cronjobs get executed on the server(s). Check with:

    crontab -l

    as root user if the two ispconfig cronjobs are listed (one cronjob executed per minute and one executed daily). If thats ok, then there must be a problem with the cron daemon itself on your system.
     
  14. binaryrogue

    binaryrogue New Member

    thank you very much!

    I modified PAM on that day when the queue on ispconfig started to queue up. It stopped root accessing crontab...

    [[email protected] /var/log]# crontab -l
    Permission denied
    You (root) are not allowed to access to (crontab) because of pam configuration.
     
  15. thecuk

    thecuk New Member

    Hello, i have same problem. My jobgueue stoped working. I think it's because i do something wrong with my crontab. When i tried the crontab -l command, I have here only my backup scripts.

    Can you tell me what to add into the crontab for ISpconfig to process queue normaly?

    Thanks a lot!
     
  16. binaryrogue

    binaryrogue New Member

    I never changed my cronjobs on my server but here's mine:

    * * * * * /usr/local/ispconfig/server/server.sh &> /dev/null
    30 00 * * * /usr/local/ispconfig/server/cron_daily.sh &> /dev/null
    0 * * * * /usr/share/awstats/tools/awstats_updateall.pl now
     

Share This Page