creating directories outside of web folder

Discussion in 'General' started by bkilinc, Dec 3, 2012.

  1. bkilinc

    bkilinc Member

    while everything is good my main problem with ISPConfig is, I cannot create directories on outside of webfolder. I need to place data files outside of web folder, which should not be accessed on web.

    I can understand that this is a security issue. But there must an option for reseller to define website directory structure. In current implemantation, there is no meaning to show outside of web folder to client, he/she can do nothing on it.

    Is it possible to write a plugin for this, which hooks to events ?
     
  2. till

    till Super Moderator

    You can create folders outside of the web folder in ispconfig. The only thing you have to do is to add the path that you want to use in the open_basedir setting of the website.

    If you want to allow this by default for all new websites, just add the oath in the openbaesdir default setting under System > server config.

    Starting with ispconfig 3.0.5, there is even a default folder for such data preconfigured, it is named /var/www/domain.tld/private
     
  3. bkilinc

    bkilinc Member

    not working, I guess

    I have added config directory and my open_basedir is as follows

    [website_path]/web:[website_path]/tmp:[website_path]/config:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin

    it did not create config directory. Also user cannot create the directory with ftp or ssh as parent directory belongs to root.
     
  4. till

    till Super Moderator

    Works fine here in all my sites.

    Thats ok for new sites, for existing sites you have to edit it on the options tab of the site.

    ISPConfig 3.0.4.6: Then you use the wrong secutoty mode. Change the secuity mode to High under System > Server config.
    ISPConfig 3.0.5: A private directory exists by default, no need to create that direcrory manually.
     
  5. bkilinc

    bkilinc Member

    thanks

    thanks for the reply.

    Right now I cannot test it. because some functions does not work in high security mode. So for the current security mode that I selected intentionaly, I still have problems. But I will try to move on to high security mode, but I cannot do it immediately.
     

Share This Page