Created sites pointing to /var/www

Discussion in 'Installation/Configuration' started by jmp51483, Feb 5, 2010.

  1. jmp51483

    jmp51483 New Member

    Hey guys,

    I can't seem to figure this out... I've created a site within ISPCONF3, and it's created the proper directory and also created the proper vhost file.. with the following information..


    <Directory /var/www/jcpsolutions.net>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/clients/client2/web5/web

    ServerName jcp.net
    ServerAlias www.jcpsolutions.net
    ServerAdmin webmaster@jcpsolutions.net

    ErrorLog /var/log/ispconfig/httpd/jcpsolutions.net/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/jcpsolutions.net/web>

    However when I browse to www.jcpsolutions.net .. it definitely directs to /var/www/ instead of the given directory. When I restart Apache I am receiving this warning:

    [Fri Feb 05 00:06:52 2010] [warn] NameVirtualHost 00.00.00.00:80 has no VirtualHosts
    [Fri Feb 05 00:06:52 2010] [warn] NameVirtualHost 00.00.00.00:443 has no VirtualHosts


    Anyone have any idea why the url won't load the proper document root?
     
  2. till

    till Super Moderator

    Select the IP address instead of * in the website settings.
     
  3. jmp51483

    jmp51483 New Member

    Hey Till,

    I did this and it did not correct the issue? any other ideas?
     
  4. till

    till Super Moderator

    Is the server installed behind a router?
     
  5. reeprich

    reeprich New Member

    Same problem

    I have the same problem, but this problem appeared only on two websites, which was created as last.
    Another five websites works without problem. Vhost files in /etc/apache2/ seems to be the same for all websites..
    ISPConfig3 on Debian Lenny - VMware virtual server...

    *** ADDITION - pointing browser to "www.mydomain.com/index.php" works well, but "www.mydomain.com" do this problem ***
     
    Last edited: Feb 12, 2010
  6. 14nw0lf

    14nw0lf New Member

    reeprich i had the same issue with the
    the way i fixed that was editing the httpd.conf file going to section 3 at the very end & delete
    and that did it for me, ispconfig is new to me still working on it to learn it dont know if that work with every distro, good luck
     
  7. yoplait

    yoplait Member

    Reeprich, you must have the default index.html page in the web folder, don't you ?
    Rename or delete it to have your website working.
     

Share This Page