created new website but it can't be viewed

Discussion in 'General' started by provell, Nov 16, 2008.

  1. provell

    provell New Member

    Hi everyone,

    I just created a new website but it is not showing up.
    When I login with it's ftp administrator account all the files are there.
    I checked the rights(chmod and chown), everything is ok.
    Even a 777 would not show anything, but I am not getting an acces error.

    When I access the site using I get the standard ispconfig site(the shared IP address one).
    If I connect with the www in front of it (, I get "this page can not be displayed". And then I get some messages saying that I might not even be connected to the internet???

    Should I delete the site and try again?
    Or would that make things worse, because it is not removing it completly and I get an error creating it again?

    Any help would be appreciated, thanks in advace.

    Rgds Edo
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you enabled the "administrator" checkbox for the FTP user before you upload the files, otherwise the files go to the user website and not to the main website.
  3. provell

    provell New Member


    I have marked the "administrator" checkbox for the FTP user.
    I have not even uploaded one file, the default index.html that ISPconfig creats is still there.
    But I am not able to see that file although I gave it 777 permissions.

    I am not getting an access denied, I am redirected to everything accepts the index.html.
    It looks as if the local DNS records are not correct.

    Is there I way I could check this by the command line?

    Rgds Edo
  4. provell

    provell New Member

    still redirected the wrong way

    I have done some testing but still nothing is making any sense.:eek:

    Created a new site -> OK (could reach it normaly, so site creation is good)
    Checked Vhosts_ispconfig.conf file -> OK (looks fine, a Vhost section is there)
    NSlookup -> OK (everything points to my server, including my severs itself)

    Please have a look at it for yourself so you understand better.

    Those errors are not access denied, right?
    They are 1. redirected wrong and 2. can't find anything

    I deleted an obsolete site, just to test if I could recreat it.
    Deleted it from ISPconfig colsole and from /var/www but I got an error message recreating it, so I'm not sure if that is a smart thing to do.:rolleyes:

    Anyway, any help would be appreciated
    Thaks in advance.:)

    Rgds Edo

    ps. I'm running Debian/etch and the latest version of ISPconfig
  5. provell

    provell New Member


    Oke, I think I found something wrong.
    The table isp_isp_domain of the ISPconfig database is missing an entry for the wrongly redirected website.

    Is this of any help?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If the domain is missing then create it trough ispconfig. ISPConfig can not configure domains that you did not create in the ispconfig interface.
  7. provell

    provell New Member

    was created

    Hi Till, thanks for your interest again.

    This is just the problem I am trying to explain.
    I HAVE created the site in the ISPconfig console.
    I can see it in the sites tree vieuw, and the files are also created in /var/www/webx

    BUT, if I try viewing the site using IExplorer(or thunderbird) there is no site showing up. :confused:
    Something went wrong with creating just this site????
    It is not an access denied problem, there is no redirection.

    How do I fix this problem the best way?
    Maybee the best thing is to delete everything that aready exists and recreate the site in the ISPConfig console.

    What files and table entry's must be deleted?
    Should I delete some DNS entry's as whel?

    Thaks for your help...

    Rgds Edo
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Never edit anything in the database manaually if you dont want to crash your system! And deleeting the domain and recreating does not change anything. Instaed you should check that you entered the correct domain name, that the domain really points to the selcted IP etc.
  9. provell

    provell New Member

    name is correct

    Hi, thaks for your anwser.

    I already checked the name and IPaddress a 100 times, and I can't find anything wrong with it.
    What about the fact that it shows up in the site tree in ISPconfig but not in the isp_isp_domain table of the ISPconfig database.
    If the site was setup correct, shouldn't it have an entry in there?

    Not planning on editing things in the database manualy, just trying to figure out what is wrong an get the site up ;)
  10. provell

    provell New Member

    fixed it

    Ok, I fixed it.
    Onder the tab Co-domains there was just one entry for the IPaddress.
    No entry for the domain.
    I added the domain and tada.

    Had to add the vhost file a bit but it's working fine now.

Share This Page